Ask Your Question
0

Compute node is down in nova service list liberty

asked 2016-06-17 11:27:29 -0500

lkesh gravatar image

I am trying to add a compute to an existing Controller. Following the install doc for liberty, when I try install the nova-compute it installs a different version of nova services (there is a mismatch of versions between controller and new compute). And when I start nova-compute it stays down and I get the following log messages .. Can anyone help me solving this issue.

File "/usr/lib/python2.7/dist-packages/nova/objects/compute_node.py", line 425, in get_all_by_host 2016-06-17 07:43:58.384 6446 TRACE nova.openstack.common.threadgroup raise exception.ComputeHostNotFound(host=host) 2016-06-17 07:43:58.384 6446 TRACE nova.openstack.common.threadgroup 2016-06-17 07:43:58.384 6446 TRACE nova.openstack.common.threadgroup ComputeHostNotFound: Compute host vtl-compute-4 could not be found. 2016-06-17 07:43:58.384 6446 TRACE nova.openstack.common.threadgroup 2016-06-17 07:43:58.384 6446 TRACE nova.openstack.common.threadgroup

root@controller:/home/lkesavan# nova service-list +----+------------------+---------------+----------+---------+-------+----------------------------+-----------------+ | Id | Binary | Host | Zone | Status | State | Updated_at | Disabled Reason | +----+------------------+---------------+----------+---------+-------+----------------------------+-----------------+ | 1 | nova-compute | compute2 | compute2 | enabled | up | 2016-06-17T15:40:39.000000 | - | | 2 | nova-compute | compute1 | compute1 | enabled | up | 2016-06-17T15:40:43.000000 | - | | 3 | nova-cert | controller | internal | enabled | up | 2016-06-17T15:40:45.000000 | - | | 4 | nova-consoleauth | controller | internal | enabled | up | 2016-06-17T15:40:39.000000 | - | | 5 | nova-conductor | controller | internal | enabled | up | 2016-06-17T15:40:42.000000 | - | | 6 | nova-scheduler | controller | internal | enabled | up | 2016-06-17T15:40:42.000000 | - | | 7 | nova-compute | vtl-compute-4 | nova | enabled | down | - | - | | 8 | nova-compute | vtl-compute-3 | nova | enabled | down | - | - | +----+------------------+---------------+----------+---------+-------+----------------------------+-----------------+

edit retag flag offensive close merge delete

Comments

Check the hostname of the compute node

pjb gravatar imagepjb ( 2016-06-18 14:38:03 -0500 )edit

hostname is present. And hosts file has all the info

lkesh gravatar imagelkesh ( 2016-06-20 09:21:54 -0500 )edit

hello

Did u start libvirtd ? and plz paste the nova.conf file of new compute and assist further

Asvin gravatar imageAsvin ( 2016-06-21 15:45:02 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-07-04 20:31:54 -0500

billy gravatar image

can you able to ping vtl-compute-4 host also check the nova-conducter version in controller node conducter and compute node version should match

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-06-17 11:27:29 -0500

Seen: 390 times

Last updated: Jul 04 '16