lbaas not showing in neutron agent-list

asked 2016-06-17 00:07:29 -0600

fresher gravatar image

updated 2016-06-17 06:19:45 -0600

I have a openstack juno setup 1 (controller+neutron) node and 3 compute nodes. My lbaas agent is running as seen in the service status below.

 systemctl status neutron-lbaas-agent.service

neutron-lbaas-agent.service - OpenStack Neutron Load Balancing as a Service Agent
   Loaded: loaded (/usr/lib/systemd/system/neutron-lbaas-agent.service; enabled)
   Active: active (running) since Fri 2016-06-17 09:55:51 IST; 10min ago
 Main PID: 169162 (neutron-lbaas-a)
   CGroup: /system.slice/neutron-lbaas-agent.service
           └─169162 /usr/bin/python /usr/bin/neutron-lbaas-agent --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/lbaas_agent.ini --l...

Jun 17 09:55:51 systemd[1]: Started OpenStack Neutron Load Balancing as a Service Agent.

However when I do neutron agent-list it does not show lbaas running.

The lbaas log shows the following error: [-] Unable to retrieve ready devices

I did the following configurations for lbaas:

I added the following line in the default section of neutron.conf on my controller+neutron node:

and added lbaas at the end of the service_plugin line:


Also I uncommented the following lines in lbaas_agent.ini

interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
device_driver =

I had done a packstack setup and lbaas was not enabled from start as i had edited the answer file to not install it. So, I made the above changes and enabled the service and started it. Do I have to install haproxy separately? Please help me resolve the issue.

edit retag flag offensive close merge delete