Ask Your Question
0

Unable to connect to keystone database

asked 2016-06-14 11:47:44 -0500

PeterN gravatar image

Hello. I'm trying to install & configure keystone on openSUSE 42.1 like described in the official docs. When I run: sudo /bin/sh -c "keystone-manage db_sync" keystone

I get this:

Option "verbose" from group "DEFAULT" is deprecated for removal.  Its value may be silently ignored in the future.
2016-06-14 18:33:11.660 27213 WARNING oslo_db.sqlalchemy.engines [-] SQL connection failed. 10 attempts left.

Thats what I changed in the /etc/keystone/keystone.conf

[DEFAULT]
admin_token = ... # from openssl rand -hex 10`

[database]
connection = mysql+pymysql://keystone:PASSWORD@controller/keystone

[token]
provider = fernet

And my /etc/my.cnf.d/openstack.cnf file

[mysqld]
bind-address = 0.0.0.0
default-storage-engine = innodb
innodb_file_per_table
collation-server = utf8_general_ci
character-set-server = utf8

Can someone help me to get the keystone database running?

edit retag flag offensive close merge delete

Comments

Do you have a firewall that blocks Mysql traffic? Can you access the database manually with mysql -ukeystone -pPASSWORD? Did you create the keystone user in the database?

Bernd Bausch gravatar imageBernd Bausch ( 2017-02-21 17:17:44 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-02-20 14:35:23 -0500

mac7564 gravatar image

Are you one time fail? yes. Remove mysql and re-install!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-06-14 11:47:44 -0500

Seen: 3,002 times

Last updated: Feb 20 '17