Ask Your Question

fail to download cirros disk.img (HTTP 400)

asked 2016-06-14 02:08:09 -0500

ariel gravatar image

updated 2016-06-14 02:37:39 -0500

I'm installing mitaka on VM CentOS 7.2 (minimal installation) in my lab and using RDO packstack with answer file. I'm using proxy that was set well in /etc/environment. I got the following error that during the installation it can't down load

PuppetError: Error appeared during Puppet run:
Error: Execution of '/usr/bin/openstack image create --format shell cirros --public --container-format=bare --disk-format=qcow2 --copy-from=' returned 1: 400 Bad Request: The HTTP URL is invalid: HTTPConnectionPool(host='', port=80): Max retries exceeded with url: /0.3.4/cirros-0.3.4-x86_64-disk.img (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x6123790>: Failed to establish a new connection: [Errno -2] Name or service not known',)) (HTTP 400)

I tried to run the command from openstack admin shell and got this error:

 ~(keystone_admin)]# /usr/bin/openstack image create --format shell cirros --public --container-format=bare --disk-format=qcow2 --copy-from=
ERROR: --copy-from was given, which is an Image v1 option that is no longer supported in Image v2

The workaround that I found is to download the cirros disk.img using wget to my /root directory

# wget

(that's ensure that my proxy was set correctly) then in my answer.txt file I replaced the CONFIG_PROVISION_IMAGE_URL= to CONFIG_PROVISION_IMAGE_URL=/root/cirros-0.3.4-x86_64-disk.img

# sed -i 's/CONFIG_PROVISION_IMAGE_URL=http:\/\/\/0.3.4\/cirros-0.3.4-x86_64-disk.img/CONFIG_PROVISION_IMAGE_URL=\/root\/cirros-0.3.4-x86_64-disk.img/g' answer.txt

then I rerun the pakstack with my answer file and it pass well.

 **** Installation completed successfully ******

I still think there is a bug here because of this line that i got when I try to run the command from the admin shell:

ERROR: --copy-from was given, which is an Image v1 option that is no longer supported in Image v2
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2016-06-16 04:09:28 -0500

vishmule gravatar image

This is known bug try to create image using https url path instead of http and check if you can download the file. for more details please refer bugzilla (

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-06-14 02:08:09 -0500

Seen: 1,806 times

Last updated: Jun 16 '16