Ask Your Question
0

Unable to deploy Openstack Fuel 8.0 Mirantis on Virtualbox

asked 2016-06-12 19:38:38 -0500

Mukesh gravatar image

Hi:

I have installed Mirantis Openstack Fuel 8.0 on my Windows 10 laptop with Cygwin. I have created a Test environment with all the default configurations as per the documentation. When I click on Deploy environment option, it gives me following error.

Error Provision has failed. Failed to execute hook 'shell' Failed to run command cd / && fa_build_image --image_build_dir /var/lib/fuel/ibp --log-file /var/log/fuel-agent-env-1.log --data_driver nailgun_build_image --input_data '{"image_data": {"/boot": {"container": "gzip", "uri": "http://10.20.0.2:8080/targetimages/env_1_ubuntu_1404_amd64-boot.img.gz", "format": "ext2"}, "/": {"container": "gzip", "uri": "http://10.20.0.2:8080/targetimages/env_1_ubuntu_1404_amd64.img.gz", "format": "ext4"}}, "output": "/var/www/nailgun/targetimages", "repos": [{"name": "ubuntu", "section": "main multiverse restricted universe", "uri": "http://10.20.0.2:8080/mirrors/ubuntu", "priority": null, "suite": "trusty", "type": "deb"}, {"name": "ubuntu-updates", "section": "main multiverse restricted universe", "uri": "http://10.20.0.2:8080/mirrors/ubuntu", "priority": null, "suite": "trusty-updates", "type": "deb"}, {"name": "ubuntu-security", "section": "main multiverse restricted universe", "uri": "http://10.20.0.2:8080/mirrors/ubuntu", "priority": null, "suite": "trusty-security", "type": "deb"}, {"name": "mos", "section": "main restricted", "uri": "http://10.20.0.2:8080/mirrors/mos-repos/ubuntu/8.0", "priority": 1000, "suite": "mos8.0", "type": "deb"}, {"name": "mos-updates", "section": "main restricted", "uri": "http://10.20.0.2:8080/mirrors/mos-repos/ubuntu/8.0", "priority": 1000, "suite": "mos8.0-updates", "type": "deb"}, {"name": "mos-security", "section": "main restricted", "uri": "http://10.20.0.2:8080/mirrors/mos-repos/ubuntu/8.0", "priority": 1000, "suite": "mos8.0-security", "type": "deb"}, {"name": "mos-holdback", "section": "main restricted", "uri": "http://10.20.0.2:8080/mirrors/mos-repos/ubuntu/8.0", "priority": 1000, "suite": "mos8.0", "type": "deb"}, {"name": "Auxiliary", "section": "main restricted", "uri": "http://10.20.0.2:8080/liberty-8.0/ubuntu/auxiliary", "priority": 1150, "suite": "auxiliary", "type": "deb"}], "codename": "trusty"}'

Please advise/help.

Thank you in advance, Mukesh

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2016-07-04 08:42:32 -0500

[root@fuel lib]# dockerctl list -l Name Image Status Full container name
nginx fuel/nginx_8.0 Running fuel-core-8.0-nginx
rabbitmq fuel/rabbitmq_8.0 Running fuel-core-8.0-rabbitmq
astute fuel/astute_8.0 Running fuel-core-8.0-astute
rsync fuel/rsync_8.0 Running fuel-core-8.0-rsync
keystone fuel/keystone_8.0 Running fuel-core-8.0-keystone
postgres fuel/postgres_8.0 Running fuel-core-8.0-postgres
rsyslog fuel/rsyslog_8.0 Running fuel-core-8.0-rsyslog
nailgun fuel/nailgun_8.0 Running fuel-core-8.0-nailgun
cobbler fuel/cobbler_8.0 Running fuel-core-8.0-cobbler
ostf fuel/ostf_8.0 Running fuel-core-8.0-ostf
mcollective fuel/mcollective_8.0 Running fuel-core-8.0-mcollective

edit flag offensive delete link more
0

answered 2016-06-28 06:09:43 -0500

Md Khadeer gravatar image

updated 2016-06-28 07:52:12 -0500

There is problem with FUEL when installed on Virtual Machine. Docker Services starts but non of the containers start 1. I have tried to start containers manually

docker ps -a CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES 37813fb7408c fuel/mcollective_7.0:latest "/usr/local/bin/star 5 days ago stoic_torvalds 666d1b9d4024 fuel/mcollective_7.0:latest "/usr/local/bin/star 5 days ago Exited (0) 5 days ago fuel-core-7.0-mcollective a7f7d3db7018 fuel/cobbler_7.0:latest "/bin/sh -c /usr/loc 5 days ago Exited (0) 5 days ago fuel-core-7.0-cobbler cbe03bbfdb26 fuel/nginx_7.0:latest "/usr/local/bin/star 5 days ago Exited (0) 5 days ago fuel-core-7.0-nginx 901a0137983f fuel/ostf_7.0:latest "/bin/sh -c /usr/loc 5 days ago Exited (0) 5 days ago fuel-core-7.0-ostf c1c6cc0c8e8d fuel/nailgun_7.0:latest "/bin/sh -c /usr/loc 5 days ago Exited (0) 5 days ago fuel-core-7.0-nailgun d4a6d87af40a fuel/rsyslog_7.0:latest "/usr/local/bin/star 5 days ago Exited (0) 5 days ago fuel-core-7.0-rsyslog 41f84be4a575 fuel/astute_7.0:latest "/bin/sh -c /usr/loc 5 days ago Exited (0) 5 days ago fuel-core-7.0-astute 45de2ab00818 fuel/rsync_7.0:latest "/bin/sh -c /usr/loc 5 days ago Exited (0) 5 days ago fuel-core-7.0-rsync c1fed9c9366e fuel/keystone_7.0:latest "/usr/local/bin/star 5 days ago Exited (6) 5 days ago fuel-core-7.0-keystone 33b871c0c454 fuel/rabbitmq_7.0:latest "/usr/local/bin/star 5 days ago Exited (0) 5 days ago fuel-core-7.0-rabbitmq e7d453c27982 fuel/postgres_7.0:latest "/usr/local/bin/star 5 days ago Exited (0) 5 days ago fuel-core-7.0-postgres

I have tried reinstalling Fuel 7.0 even then the same issue occurred. All the Docker containers status shows Exited. Do anyone knows how to solve this issue. When i install it in a Physical machine it works fine.

edit flag offensive delete link more
0

answered 2016-06-22 20:06:06 -0500

Mukesh gravatar image

Hi

Thanks for the response. I checked the services status and everything seems to be fine (Command used to check: service --status-all)

I ran the command dockerctl list -l and found couple of services were not running. I started the nginx service (dockerctl start nginx) and all services were started viz. astute, rsync, rsyslog, nailgun, cobbler, ostf, and mcollective. Then I tried to deploy again and still got the same error.

I tried attaching the dockerctl list -l command output, but it is asking me for >10 points, which I am not sure how to earn those.

But as of now all the following services are running:

nginx rabbitmq astute rsync keystone postgres rsyslog nailgun cobbler ostf mcollective

Please advise!

Thanks.

edit flag offensive delete link more

Comments

Use http://paste.openstack.org/ to copy and share link, let me know the error logs

Maestropandy gravatar imageMaestropandy ( 2016-06-23 01:05:19 -0500 )edit

I cannot attach the JPEG error file using the link you mentioned. Also, I cannot install Virtualbox Guest Additions which allows to copy clipboard. The above dockerctl list -l shows me only rabbitmq and postgres service running others are stopped. What specific log do you want me to check?

Mukesh gravatar imageMukesh ( 2016-06-24 22:29:18 -0500 )edit
0

answered 2016-06-22 01:15:31 -0500

Please sign into fuel node and check all services are running fine and paste the output of

dockerctl list -l

edit flag offensive delete link more

Comments

Sorry, add some background information, I met the same problem, but in my fuel-master node, all services are running.

[root@fuel lib]# dockerctl list -l Name Image Status Full container name
nginx fuel/nginx_8.0 Running fuel-core-8.0-ngi

huangdenghui gravatar imagehuangdenghui ( 2016-07-04 08:44:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-06-12 19:38:38 -0500

Seen: 852 times

Last updated: Jun 28 '16