Ask Your Question
0

ceilometer polling strange behaviour

asked 2016-06-10 02:34:17 -0600

pepehortiz gravatar image

Hi everybody,

I'm having a strange behaviour polling two sources (network.services.lb.active.connections & compute.node.cpu.idle.percent). Both have the interval configured in pipeline.yaml to 30 seconds but I'm getting samples of compute.node.cpu every 60 seconds. Samples for lb.active connections are being received at correct interval. AFAIK, compute samples are queried by ceilometer-agent-compute and lb.active by ceilometer-agent-central. So is there any difference in how each agent reads pipeline.yaml?

Some info:

Ubuntu Xenial / Mitaka

Ceilometer 6.0.0

Nova 13.0.0

Neutron 8.1.0

Thanks all,

Pepe

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-06-12 20:53:02 -0600

Shaoman Zhang gravatar image

compute.node.cpu.idle.percent is reported by nova through notification, not by ceilometer-compute polling, so its interval is decided by nova.

edit flag offensive delete link more

Comments

Hi Shaoman, Thanks for your reply. Is there any place where configure this interval in nova? I only know instance_usage_audit_period to report information about instances.

Regards, Pepe

pepehortiz gravatar imagepepehortiz ( 2016-06-13 08:45:22 -0600 )edit

The report interval used default periodic_task, 60s by default. If you want to have a test, refer to this: https://review.openstack.org/#/c/133904/

Shaoman Zhang gravatar imageShaoman Zhang ( 2016-06-13 21:06:32 -0600 )edit

This solvs my doubts.

Thank you Shaoman.

pepehortiz gravatar imagepepehortiz ( 2016-06-14 02:53:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-06-10 02:34:17 -0600

Seen: 112 times

Last updated: Jun 12 '16