Ask Your Question
0

Using http proxy in Horizon for image download

asked 2016-06-09 07:19:55 -0600

Herr-Herner gravatar image

updated 2016-06-09 07:20:50 -0600

We must use an http proxy to get access to the internet. I have set up OpenStack Mitaka, but I cannot find a way to tell Horizon (Dashboard) to use our http proxy for image creation if someone stated a valid url in the UI as image location.I have already created a proxy.sh script in the folder etc/profile.d which exports the variables http_proxy, https_proxy and no_proxy. When I use the glance CLI for image creation, everything is working as expected and the image gets downloaded via the http proxy, but it does not work from within Horizon's UI.

Has someone an idea how to get image download working when Horizon has to use an http proxy?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-06-09 09:21:21 -0600

Herr-Herner gravatar image

updated 2016-06-09 09:35:54 -0600

I think I can answer my own question. The problem was a misconfiguration of Glance, Horizon has nothing to do with the issue described above.

glance-api.conf requires the following additional entries:

stores = file,http,...
http_proxy_information = http:os-proxy:3128,https:os-proxy:3128,ftp:os-proxy:3128

Now the image file gets downloaded from the remote location specified in Horizon's UI.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-06-09 07:19:55 -0600

Seen: 818 times

Last updated: Jun 09 '16