Ask Your Question
0

Mitaka Cinder SSL issue

asked 2016-06-08 05:52:53 -0500

SiWeir gravatar image

updated 2016-06-09 04:23:26 -0500

Hi All,

I've upgraded to Mitaka from Juno and I've got everything to work correctly using the SSL options except for Cinder.

I've set the options under [ssl] of the cinder.conf file but when the api service starts up it seems to ignore the ssl options and start as http rather than https as the log entry below shows:

eventlet.wsgi.server [-] (43330) wsgi starting up on http ://0.0.0.0:8776/

When I enable debug and restart the service there is no mention of the parameters under the [ssl] section.

Is this a bug with cinder and is there any workaround?

I've been reading some other posts (https://bugs.launchpad.net/puppet-cinder/+bug/1565925 (https://bugs.launchpad.net/puppet-cin...)) and I'm wondering if the ssl options have been removed but I'm not sure how to enable the cinder-api as an apache wsgi process.

So far I have completed the tasks listed here (http://docs.openstack.org/developer/cinder/devref/api.apache.html (http://docs.openstack.org/developer/c...)) but I'm not struggling with the SELinux. I'm getting an the following error:

IOError: [Errno 13] Permission denied: '/var/log/cinder/osapi_volume.log'

Any help would be appreciated.

Thanks,

Simon

edit retag flag offensive close merge delete

Comments

I've been through all the configuration options several times and I can't see anything that I have missed.

From the logs it appears when cinder-api is starting up it isn't reading the options from the [ssl] section.

SiWeir gravatar imageSiWeir ( 2016-06-09 04:22:55 -0500 )edit

I have the same problem. I've upgraded to Mitaka from Liberty wsgi starting up on http://0.0.0.0:8776/ not https

starykh sergey gravatar imagestarykh sergey ( 2016-07-26 12:32:44 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-03-26 18:39:28 -0500

Hi I had this problem One thing I had to do was to put the volume backend config at the end of the cinder config.

If I had the volume backend configuration just after the enabled_backend option the ssl options and debug options wouldn't be loaded

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-06-08 05:52:53 -0500

Seen: 357 times

Last updated: Jun 09 '16