Ask Your Question
1

how to enable keystone v2 on mitaka

asked 2016-06-07 09:21:11 -0500

senyapsudah gravatar image

Hi Guys,

Currently we are running on mitaka. it has been configured based on the recommended document guide which using v3 api for keystone. However, we have some issue on integration with our billing system. currently the module is using v2 api. we have no issue with v3. but when we try to use v2 it seems like we cannot authenticate.

is there anyway that we can allow authentication using v2 api?

edit retag flag offensive close merge delete

Comments

Hello,

Seeing the same problem. Got anywhere with this?

Any tips warmly welcomed!

Peter

Peter gravatar imagePeter ( 2016-06-12 02:44:58 -0500 )edit

Please help. Need same information how to enable v2 in Mitaka.

Murali G D gravatar imageMurali G D ( 2016-06-17 05:41:30 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
4

answered 2016-06-17 06:00:46 -0500

Peter gravatar image

I eventually got it going by adding the default domain id (not name) in keystone.conf

E.g.

...

[identity]

default_domain_id = e4de7fbf3e9d4a9d9a5a3a43d6690d58

....

edit flag offensive delete link more

Comments

hi peter, yup. you need to add that to the keystone. sorry for the delay to answer you.

senyapsudah gravatar imagesenyapsudah ( 2016-06-18 22:57:48 -0500 )edit

Hi you did only this thing? If i add this and restart keystone i have the same authentication problem like before...

luke29 gravatar imageluke29 ( 2016-08-19 02:26:13 -0500 )edit
0

answered 2016-12-20 07:39:07 -0500

Vinoth gravatar image

Hi, After adding default_domain_id in the /etc/keystone/keystone.conf file,

[identity] 

default_domain_id  = xxxxxxxx32ea5xxxxx2b6f93

Don't forget to run Keystone DB sync.

su -s /bin/sh -c "keystone-manage --config-file /etc/keystone/keystone.conf db_sync" keystone

Then, Restart the apache service.

edit flag offensive delete link more

Comments

How can i get the default_domain_id ?

pazzo_marza gravatar imagepazzo_marza ( 2016-12-26 18:45:13 -0500 )edit

Hi, you can get the default_domain_id with the following command: openstack domain list

haja gravatar imagehaja ( 2017-01-05 06:08:39 -0500 )edit
0

answered 2016-06-19 23:38:49 -0500

Murali G D gravatar image

Hi Peter

Thanks. Your suggestion worked for me.

Murali G D

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2016-06-07 09:21:11 -0500

Seen: 2,502 times

Last updated: Dec 20 '16