How to install designate and trove on OpenStack Kilo (Ubuntu 14.04) deployed with Mirantis Fuel 7.0

asked 2016-06-06 10:27:37 -0500

animaletdesequia gravatar image

We've set a basic environment using Mirantis Fuel with 3 controller/storage nodes and 3 computes. We've used Fuel to install the base system and then we added some extra components like FWaaS plugin for neutron.

The problem we're facing now is we can add some other components like designate (DNSaaS) nor trove (DBaaS). Wheater I follow the official guides from git-hub (trying to compile from python sources) or add some extra repos (ubuntu-cloud-archive) I always run into dependency problems.

I think the problem is, some of the packages installed trough fuel are not ubuntu natives but re-compiled and modified by mirantis. For example, if I list some neutron packages:

dpkg -l | grep neutron
ii  neutron-common                      1:2015.1.1-1~u14.04+mos5355            all          Neutron is a virtual network service for Openstack - common
ii  neutron-dhcp-agent                  1:2015.1.1-1~u14.04+mos5355            all          Neutron is a virtual network service for Openstack - DHCP agent
rc  neutron-l3-agent                    1:2015.1.1-1~u14.04+mos5348            all          Neutron is a virtual network service for Openstack - l3 agent
ii  neutron-lbaas-agent                 1:2015.1.1-1~u14.04+mos739             all          Neutron is a virtual network service for Openstack - LBaaS agent
ii  neutron-metadata-agent              1:2015.1.1-1~u14.04+mos5355            all          Neutron is a virtual network service for Openstack - metadata agent
ii  neutron-plugin-ml2                  1:2015.1.1-1~u14.04+mos5355            a

They have a base version and an added mos (Mirantis OpenStack) version.

If I try to install trove this happens:

apt-get install trove-api
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 trove-api : Depends: trove-common but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This happens in a lot of packages. So my question would be, is ther a way to add extra packages for this specific distribution of MOS? Maybe some Mirantis extra repo?

Thanks

edit retag flag offensive close merge delete