Ask Your Question
0

Quantum Failed reporting state, failed synchronizing routers [closed]

asked 2013-05-09 07:50:16 -0600

snooper gravatar image

updated 2013-06-11 10:26:05 -0600

fifieldt gravatar image

hello,

We are trying to install openstack using basic install guide (Grizzly). And we can't find the solution to the errors: ERROR [quantum.agent.dhcpagent] Failed reporting state! ERROR [quantum.agent.l3agent] Failed synchronizing routers

I don't kow how to solve it please help!

dhcp.agent.ini:

[DEFAULT]
enable_isolated_metadata = True
enable_metadata_network = True

quantum.conf

[DEFAULT]

verbose = True
rabbit_password = Ferrari23
rabbit_host = 10.10.10.10
rabbir_userid = guest


# Where to store lock files
lock_path = $state_path/lock


# Address to bind the API server
bind_host = 0.0.0.0

# Port the bind the API server to
bind_port = 9696



# =========== items for agent management extension =============

# ===========  end of items for agent management extension =====

# =========== items for agent scheduler extension =============


[QUOTAS]

[DEFAULT_SERVICETYPE]


[AGENT]


# ===========  end of items for agent management extension =====

[keystone_authtoken]
auth_host = 10.10.10.10
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = quantum
admin_password = Ferrari23
signing_dir = /var/lib/quantum/keystone-signing
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-06-05 21:20:18.088829

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-05-10 10:46:21 -0600

darragh-oreilly gravatar image

Check the logs.Your quantum.conf is missing many RPC configuration options.

edit flag offensive delete link more

Comments

default values should be good. I think we need more info from logs here

Davide Guerri gravatar imageDavide Guerri ( 2013-08-02 07:52:26 -0600 )edit
0

answered 2013-08-02 07:54:48 -0600

Davide Guerri gravatar image

updated 2013-08-02 07:59:13 -0600

Got the same error turned out that I was using the wrong (non-existant) database in ovs_quantum_plugin.ini

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-09 07:50:16 -0600

Seen: 1,457 times

Last updated: Aug 02 '13