Ask Your Question
0

br-tun is not created and port-bind fail: openstack Mitaka

asked 2016-05-31 00:04:36 -0500

Sanjay_1987 gravatar image

updated 2016-05-31 02:12:44 -0500

I have created a 3 node setup with Mitaka release. I am using openvswitch agent instead of linuxbridge agent. The tenant_network_type in ml2_conf.ini is "GRE" But : 1) "ovs-vsctl show" doesn't show any tunnel bridges created, only br-int is there. not br-tun, no br-ex nothing. I am not able to understand why its not created. 2) at the time of VM creartion, it shows follwing error in neutron-server.log

*

ERROR neutron.plugins.ml2.managers [req-916839fb-9c36-4340-8c82-5165dfac5b0f - - - - -] Failed to bind port 97eb531a-20ad-4f02-a46b-7fd30e55aab6 on host network for vnic_type normal using segments [{'segmentation_id': 88, 'physical_network': None, 'id': u'0633a036-5269-475f-a76b-fb122b11f51b', 'network_type': u'gre'}]
WARNING neutron.plugins.ml2.rpc [req-d5e8bf79-dccc-4319-9b4b-3ee02335e9df - - - - -] Device 97eb531a-20ad-4f02-a46b-7fd30e55aab6 requested by agent ovs-agent-network on network 689b5dc0-5413-43a5-b2ca-3866c8b449ff not bound, vif_type: binding_failed

*

And hence if I proceed with VM spawning, it failed.

Can anyone help me out here?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2016-08-09 13:05:46 -0500

Naushad gravatar image

Can you please explain how to start openvswitch service manually using "--config-file=/etc/neutron/plugins/ml2/ml2_conf.ini " option

edit flag offensive delete link more

Comments

He showed how to do this in his answer to this question: https://ask.openstack.org/en/question/80530/unable-to-launch-instances-unexpected-vif_typebinding-failed/?answer=93534#post-id-93534 (https://ask.openstack.org/en/question...)

Furt Koto gravatar imageFurt Koto ( 2016-09-30 01:45:12 -0500 )edit
0

answered 2016-06-01 03:52:51 -0500

Sanjay_1987 gravatar image

Hi,

Solved this. Stopped the services on Compute & controller node for openvswitch agent. Started them manually with "--config-file=/etc/neutron/plugins/ml2/ml2_conf.ini " option. Earlier they are using only openvswitch_agent.ini file as config file. I started them manually and added these files. It is working now.

Thanks Peter for the hint.

edit flag offensive delete link more
1

answered 2016-05-31 03:38:10 -0500

updated 2016-05-31 03:42:29 -0500

You haven't specified which OpenStack distribution you are using, so I'll assume it's Ubuntu. Afaik, Mitaka packages have moved from ml2_conf.ini to openvswitch_agent.ini, so the config file you mention might not be read at all. You can check this by listing the running Neutron processes and search for the filename in the process name, or looking at the neutron-openvswitch-agent initscript/upstart job/systemd job file.

If you are sure the correct plugin file is being read, I suggest setting debug=True in neutron.conf and restarting neutron-openvswitch-agent. This way you will be able to trace the agent's bootstrap process and see which openvswitch commands it runs (those logs are present in /var/log/neutron/openvswitch-agent.log).

edit flag offensive delete link more

Comments

Hello Peter, Thanks for your reply. Yes, its Ubuntu. As per your suggestion I have checked the config file, openvswitchagent.ini in the ,listing on neutron process. I noticed that openvswitch_agent.ini is being read by both compute and network openvswitch agents. continue in next msg:

Sanjay_1987 gravatar imageSanjay_1987 ( 2016-06-01 00:09:37 -0500 )edit

Compute Node: ps -eaf|grep openvswitch_agent.ini neutron 1507 1 2 May30 ? 00:55:11 /usr/bin/python /usr/bin/neutron-openvswitch-agent --config-file=/etc/neutron/neutron.conf --config-file=/etc/neutron/plugins/ml2/openvswitch_agent.ini --log-file=/var/log/neutron/openvswitch-agent.

Sanjay_1987 gravatar imageSanjay_1987 ( 2016-06-01 00:10:15 -0500 )edit

Network Node: ps -eaf|grep openvswitch_agent.ini neutron 18710 1 2 May31 ? 00:30:45 /usr/bin/python /usr/bin/neutron-openvswitch-agent --config-file=/etc/neutron/neutron.conf --config-file=/etc/neutron/plugins/ml2/openvswitch_agent.ini --log-file=/var/log/neutron/openvswitch-agent.l

Sanjay_1987 gravatar imageSanjay_1987 ( 2016-06-01 00:11:13 -0500 )edit

But I noticed that, on both compute and network node, none of agents are using ml2_conf.ini. Only neutron_server on controller node is running using the ml2_conf.ini file. Is that expected or something wrong in here?

Sanjay_1987 gravatar imageSanjay_1987 ( 2016-06-01 00:17:07 -0500 )edit

Also I enabled the debug logs for neutron server and while VM spawning, I can see : DEBUG neutron.plugins.ml2.drivers.mech_agent Network is of type gre but agent compute or mechanism driver only support ['local', 'flat', 'vlan']. check_segment_for_agent /usr/lib/python2.7/dist-packages/neutron/plugi

Sanjay_1987 gravatar imageSanjay_1987 ( 2016-06-01 00:22:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-05-31 00:04:36 -0500

Seen: 1,858 times

Last updated: Aug 09 '16