Ask Your Question
0

Ceilometer alarm create fail (Table 'aodh.alarm' doesn't exist)

asked 2016-05-30 04:42:16 -0500

Kobi gravatar image
Hi all,

I followed the installation guide on official website to install Mitaka and services worked well.
(http://docs.openstack.org/mitaka/install-guide-rdo/)

But, when I create the ceilometer alarm, there is an error occurs. (refer from http://docs.openstack.org/admin-guide/telemetry-alarms.html)
The below is the ceilometer command:
[root@controller]# ceilometer alarm-threshold-create --name cpu_hi \
>   --description 'instance running hot' \
>   --meter-name cpu_util --threshold 70.0 \
>   --comparison-operator gt --statistic avg \
>   --period 600 --evaluation-periods 3 \
>   --alarm-action 'log://' \
>   --query resource_id=347c6d93-6075-433c-9dee-50464241ad39

The below is the error message from "/var/log/aodh/api.log":
(pymysql.err.ProgrammingError) (1146, u"**Table 'aodh.alarm' doesn't exist**") [SQL: u'SELECT alarm.alarm_id AS alarm_alarm_id, alarm.enabled AS alarm_enabled, alarm.name AS alarm_name, alarm.type AS alarm_type, alarm.severity AS alarm_severity, alarm.description AS alarm_description, alarm.timestamp AS alarm_timestamp, alarm.user_id AS alarm_user_id, alarm.project_id AS alarm_project_id, alarm.state AS alarm_state, alarm.state_timestamp AS alarm_state_timestamp, alarm.ok_actions AS alarm_ok_actions, alarm.alarm_actions AS alarm_alarm_actions, alarm.insufficient_data_actions AS alarm_insufficient_data_actions, alarm.repeat_actions AS alarm_repeat_actions, alarm.rule AS alarm_rule, alarm.time_constraints AS alarm_time_constraints \nFROM alarm \nWHERE alarm.name = %s AND alarm.project_id = %s ORDER BY alarm.timestamp DESC'] [parameters: (u'cpu_hi', u'4016296c935a4aa2ac2f860faf3b7f8d')] (HTTP 500) (Request-ID: req-2addd66b-80c3-4db2-ba63-b5238eb95226)


I also checked out the database 'aodh', it is empty.
The below is the command:
[root@controller ~]# mysql -u root -p
Enter password:
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 4817
Server version: 10.1.12-MariaDB MariaDB Server

Copyright (c) 2000, 2016, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> show databases;
+--------------------+
| Database           |
+--------------------+
| aodh               |
| cinder             |
| glance             |
| heat               |
| information_schema |
| keystone           |
| mysql              |
| neutron            |
| nova               |
| nova_api           |
| performance_schema |
+--------------------+
11 rows in set (0.02 sec)

MariaDB [(none)]> use aodh
Database changed
MariaDB [aodh]> show tables;
Empty set (0.00 sec)

MariaDB [aodh]> quit
Bye
[root@controller ~]#


How do I solve this issue?
Appreciated for your help!!
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
3

answered 2016-05-30 06:43:27 -0500

Shaoman Zhang gravatar image

Try to use aodh-dbsync to initialise aodh database.

edit flag offensive delete link more

Comments

Hi Shaoman, Thanks for your reply. It works!

Kobi gravatar imageKobi ( 2016-05-30 08:04:13 -0500 )edit
0

answered 2017-09-24 01:08:35 -0500

wildloop gravatar image

updated 2017-09-24 01:11:04 -0500

Populate aodh database step is still missing (Packstack Pike) - https://bugs.launchpad.net/openstack-manuals/+bug/1585739 (bug)

Execute:

$ su -s /bin/sh -c "aodh-dbsync --config-file=/etc/aodh/aodh.conf" aodh
$ sudo chown -R aodh:aodh /var/log/aodh/
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-05-30 04:42:16 -0500

Seen: 1,226 times

Last updated: Sep 24 '17