Ask Your Question

Linux Bridge agent failed to start in Compute node

asked 2016-05-20 15:37:53 -0500

dashpartha gravatar image

updated 2016-05-23 16:07:23 -0500

Hi All,

Here is the setup details i have in my environment OPENSTACK MITAKA installed on CentOS7.1

1- Controller node-IP- with one NIC and interface name is-eno16777984

2- Compute node-IP- with one NIC and interface name is-eno16777984


i have given following in controller node & now i would like to know which IP should i give in Compute node in same

configuration file in Controller node: /etc/neutron/plugins/ml2/linuxbridge_agent.ini

physical_interface_mappings = provider:eno16777984

----------->neutron-linuxbridge-agent.service is working fine in controller node

[root@compute1 ~]# systemctl status neutron-linuxbridge-agent.service
● neutron-linuxbridge-agent.service - OpenStack Neutron Linux Bridge Agent
   Loaded: loaded (/usr/lib/systemd/system/neutron-linuxbridge-agent.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2016-05-19 17:40:07 PDT; 17h ago
  Process: 7587 ExecStart=/usr/bin/neutron-linuxbridge-agent --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/linuxbridge_agent.ini --config-dir /etc/neutron/conf.d/common --config-dir /etc/neutron/conf.d/neutron-linuxbridge-agent --log-file /var/log/neutron/linuxbridge-agent.log (code=exited, status=1/FAILURE)
 Main PID: 7587 (code=exited, status=1/FAILURE)

May 19 17:40:06 systemd[1]: Started OpenStack Neutron Linux Bridge Agent.
May 19 17:40:06 systemd[1]: Starting OpenStack Neutron Linux Bridge Agent...
May 19 17:40:06 neutron-linuxbridge-agent[7587]: Guru mediation now registers SIGUSR1 and SIGUSR2 by default for backward compatibility. SIGUSR1 will no longer be registered in a future release...rate reports.
May 19 17:40:07 neutron-linuxbridge-agent[7587]: Option "verbose" from group "DEFAULT" is deprecated for removal.  Its value may be silently ignored in the future.
May 19 17:40:07 neutron-linuxbridge-agent[7587]: Option "notification_driver" from group "DEFAULT" is deprecated. Use option "driver" from group "oslo_messaging_notifications".
May 19 17:40:07 systemd[1]: neutron-linuxbridge-agent.service: main process exited, code=exited, status=1/FAILURE
May 19 17:40:07 systemd[1]: Unit neutron-linuxbridge-agent.service entered failed state.
May 19 17:40:07 systemd[1]: neutron-linuxbridge-agent.service failed.
Hint: Some lines were ellipsized, use -l to show in full

configuration file in Compute node: /etc/neutron/plugins/ml2/linuxbridge_agent.ini

physical_interface_mappings = provider

:---------->>>Please suggest what IP should i give in compute node

I have given controller node IP,interface name but nothing worked out. So i would need some help to get this fixed

Thanks Partha

edit retag flag offensive close merge delete


I reckon this is a config file parsing problem.

darragh-oreilly gravatar imagedarragh-oreilly ( 2016-05-24 07:37:49 -0500 )edit

Hi Reckon, Please let me know where am i doing wrong

dashpartha gravatar imagedashpartha ( 2016-05-24 09:43:25 -0500 )edit

Hi Reckson,

Do you have any clue

dashpartha gravatar imagedashpartha ( 2016-05-24 14:12:51 -0500 )edit

nope. Maybe one of your many config files has invalid format.

darragh-oreilly gravatar imagedarragh-oreilly ( 2016-05-24 14:50:39 -0500 )edit

@darragh-oreilly, what are you suspecting here. please let me know

dashpartha gravatar imagedashpartha ( 2016-05-24 15:14:24 -0500 )edit

2 answers

Sort by » oldest newest most voted

answered 2016-05-23 20:41:35 -0500

Carrot gravatar image

If you use provider network only, do not need to set IP in /etc/neutron/plugins/ml2/linuxbridge_agent.ini

Controller Node

physical_interface_mappings = provider:eno16777984

Compute Node

physical_interface_mappings = provider:????

fill '????' with computer node's physical interface name.

edit flag offensive delete link more


Hi Carrot, The controller & compute node are both virtual machines & both are running same OS(CentOS7.1)with same network interface name but IP's are different. When i am giving "eno33557248" it not coming UP. i am confused which one is my Provider Network. Please suggest

dashpartha gravatar imagedashpartha ( 2016-05-23 22:20:36 -0500 )edit

So, compute node's linuxbridge_agent.ini set : physical_interface_mappings = provider:eno33557248 , right? attached the config file and error log plz.

Carrot gravatar imageCarrot ( 2016-05-24 00:36:26 -0500 )edit

Hi Carrot, Can you please let me know how to upload the files here. i am new to this forum so couldn't find the way to do

dashpartha gravatar imagedashpartha ( 2016-05-24 01:57:06 -0500 )edit


The issue got resolved & now the Linux bridge agent is running on Compute node

dashpartha gravatar imagedashpartha ( 2016-05-24 17:20:04 -0500 )edit

answered 2016-05-23 18:28:08 -0500

dashpartha gravatar image


Can anyone please answer. I am still waiting

Thanks Partha

edit flag offensive delete link more



The issue got resolved now & i did it by myself

dashpartha gravatar imagedashpartha ( 2016-05-24 17:18:50 -0500 )edit

ok good. Please update this "answer" with the solution so others can benefit from your experience

darragh-oreilly gravatar imagedarragh-oreilly ( 2016-05-25 02:20:08 -0500 )edit

Indeed, I am looking for this answer as well...

hvanschaick gravatar imagehvanschaick ( 2016-05-25 04:34:57 -0500 )edit


i had not created Management Network & Private Network. Later i realized & created. after that the linux bridge agent started working automatically with same set of configuration. i have followed this link---> (

dashpartha gravatar imagedashpartha ( 2016-05-26 17:26:13 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2016-05-20 15:37:53 -0500

Seen: 8,279 times

Last updated: May 23 '16