how we should configurate virtualbox to create the provider and managment network as in the docs of openstack mitaka on virtualbox?

asked 2016-05-19 13:50:38 -0500

nicolas gravatar image

Hello everyone again.

I've mounted a basic Openstack following this guide: http://docs.openstack.org/mitaka/install-guide-ubuntu/ (http://docs.openstack.org/mitaka/inst...) I have everything working but I can't ping instances and they don't have access to the internet even if they have an IP assigned(I'm using the provider network option). I think is because the configuration of interfaces. I have VirtualBox controller working like this: 1 NIC Mode: NAT Network (As management network)

1 NIC Mode: Host only (As provider network)

And here are the interfaces file of each machine(controller and nova).

Controller:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 10.0.0.11
network 10.0.0.0
netmask 255.255.255.0
gateway 10.0.0.1

auto eth1
iface eth1 inet manual
        up ip link set dev $IFACE up
        down ip link set dev $IFACE down

Nova

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 10.0.0.31
network 10.0.0.0
netmask 255.255.255.0
gateway 10.0.0.1

# The provider network interface
auto eth1
iface  eth1 inet manual
up ip link set dev $IFACE up
down ip link set dev $IFACE down

Thanks you very much.

edit retag flag offensive close merge delete

Comments

I'm in the same situation. I followed the install instructions several times and have tried the self-service as well as provider network setup from the Mitaka install instructions. Both have resulted in non-working environments as you described. If anyone has an answer it would be appreciated!

Jack Hefner gravatar imageJack Hefner ( 2016-05-25 13:43:23 -0500 )edit

I have same issues

grkim gravatar imagegrkim ( 2016-10-30 10:10:26 -0500 )edit