Ask Your Question
0

Unable to delete loadbalancer

asked 2016-05-16 11:58:01 -0500

ajithpathiyil gravatar image

Hi Team,

I am unable to delete a load balancer that seems to have struck in PENDING_CREATE status.

Error: Failed to delete port: Request Failed: internal server error while processing your request.

Is anybody having a similar issue.

My environment is on Liberty release, LBaaS V2

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2019-08-24 10:24:53 -0500

Hi everybody,

In my case, I first change the state of the lb to ERROR and remove it...

mysql -u octavia -p

USE octavia; SELECT * FROM load_balancer WHERE provisioning_status LIKE "PENDING_CREATE"; UPDATE load_balancer SET provisioning_status = 'ERROR' WHERE provisioning_status LIKE "PENDING_CREATE";

Now you can delete: openstack loadbalancer delete YOUR_LB_IN_ERROR_ID

:-) Happy to share...

edit flag offensive delete link more
0

answered 2016-05-18 01:28:51 -0500

ajithpathiyil gravatar image

Hi team,

I was able to find the workaround for this, My Orphaned loadbalancer ports that was not getting deleted was because of the entries in the neutron tables

1) lbaas_loadbalancers 2) lbaas_loadbalancer_statistics

Removed 3 orphaned entried from lbaas_loadbalancer_statistics (Had foreign key references) then, followed by removal of 3 entries from lbaas_loadbalancers.

It worked like charm, All 3 of my public ip's held by these orphaned ports were released to the public subnet again

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-05-16 11:58:01 -0500

Seen: 1,103 times

Last updated: May 18 '16