Ask Your Question
1

Openstack offline installation on centos 7 [closed]

asked 2016-05-11 02:17:12 -0600

pandia gravatar image

updated 2016-05-12 04:25:52 -0600

I am trying to install and configure Openstack Kilo on CentOS 7 by Offline mode.

As first step I have created and downloaded all repository of centos in machine using below link.

http://www.tecmint.com/setup-yum-repository-in-centos-7/

So Local repo directory installation completed and also I have changed repo link to server IP.

When I'm executing yum update or yum install it shows some error which is posted below.

[root@localhost yum.repos.d]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

Resolving Dependencies
--> Running transaction check
---> Package NetworkManager.x86_64 1:0.9.9.1-13.git20140326.4dba720.el7 will be obsoleted
---> Package NetworkManager.x86_64 1:1.0.6-29.el7_2 will be obsoleting
--> Processing Dependency: NetworkManager-libnm(x86-64) = 1:1.0.6-29.el7_2 for package: 1:NetworkManager-1.0.6-29.el7_2.x86_64
--> Processing Dependency: libnl3 >= 3.2.21-7 for package: 1:NetworkManager-1.0.6-29.el7_2.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_0_6)(64bit) for package: 1:NetworkManager-1.0.6-29.el7_2.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_0_4)(64bit) for package: 1:NetworkManager-1.0.6-29.el7_2.x86_64
--> Processing Dependency: libnm.so.0(libnm_1_0_0)(64bit) for package: 1:NetworkManager-1.0.6-29.el7_2.x86_64
--> Processing Dependency: libnm.so.0()(64bit) for package: 1:NetworkManager-1.0.6-29.el7_2.x86_64
---> Package NetworkManager-adsl.x86_64 1:1.0.6-29.el7_2 will be obsoleting
---> Package NetworkManager-bluetooth.x86_64 1:1.0.6-29.el7_2 will be obsoleting
--> Processing Dependency: libbluetooth.so.3()(64bit) for package: 1:NetworkManager-bluetooth-1.0.6-29.el7_2.x86_64
---> Package NetworkManager-glib.x86_64 1:0.9.9.1-13.git20140326.4dba720.el7 will be updated
---> Package NetworkManager-glib.x86_64 1:1.0.6-29.el7_2 will be an update
---> Package NetworkManager-team.x86_64 1:1.0.6-29.el7_2 will be obsoleting
---> Package NetworkManager-tui.x86_64 1:0.9.9.1-13.git20140326.4dba720.el7 will be updated
---> Package NetworkManager-tui.x86_64 1:1.0.6-29.el7_2 will be an update
---> Package NetworkManager-wifi.x86_64 1:1.0.6-29.el7_2 will be obsoleting
---> Package NetworkManager-wwan.x86_64 1:1.0.6-29.el7_2 will be obsoleting
---> Package avahi.x86_64 0:0.6.31-13.el7 will be updated
---> Package avahi.x86_64 0:0.6.31-15.el7_2.1 will be an update
---> Package avahi-autoipd.x86_64 0:0.6.31-13.el7 will be updated
---> Package avahi-autoipd.x86_64 0:0.6.31-15.el7_2.1 will be an update
---> Package avahi-libs.x86_64 0:0.6.31-13.el7 will be updated
---> Package avahi-libs.x86_64 0:0.6.31-15.el7_2.1 will be an update
---> Package bind-libs-lite.x86_64 32:9.9.4-14.el7 will be updated
---> Package bind-libs-lite.x86_64 32:9.9.4-29.el7_2.3 will be an update
---> Package bind-license.noarch 32:9.9.4-14.el7 will be updated
---> Package bind-license.noarch 32:9.9.4-29.el7_2.3 will be an update
---> Package ca-certificates.noarch 0:2013.1.95-71.el7 will be updated
---> Package ca-certificates.noarch 0:2015.2.6-70.1.el7_2 will be an update
---> Package coreutils.x86_64 0:8.22-11.el7 will be updated
---> Package coreutils.x86_64 0:8.22-15.el7_2.1 will be an update
---> Package cronie.x86_64 0:1.4.11-11 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by pandia
close date 2016-05-23 08:14:00.891573

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-05-12 02:46:13 -0600

gbraad gravatar image

updated 2016-05-12 04:16:09 -0600

The errors you are seeing are related to dependencies not being met by the yum update. What were the steps you did before the yum update ?

Please make sure your machine is in a usable state and you can perform an update before trying to install OpenStack. The information provided is not enough to pinpoint what causes the problem:

  • Which packages did you pull to create your local update repo?
  • Which version of CentOS do you have? $ cat /etc/redhat-release
  • Which repos are defined on your machine? $ ls /etc/yum.repos.d
  • Why do you want to perform an offline installation of Kilo?

If you want an easy to install OpenStack environment, based on Liberty or Mitaka, on CentOS 7; it might be a good idea to look at: https://www.rdoproject.org/install/quickstart/ (https://www.rdoproject.org/install/qu...)

Only a small set of commands is needed to install OpenStack: https://github.com/gbraad/oneliners/blob/master/install_packstack.sh (https://github.com/gbraad/oneliners/b...) as an all-in-one.

the rdo-release.rpm now points to https://repos.fedorapeople.org/repos/openstack/openstack-mitaka/rdo-release-mitaka-2.noarch.rpm. This archive contains two repo files, which point to

  • http://mirror.centos.org/centos/7/cloud/x86_64/openstack-mitaka/
  • http://buildlogs.centos.org/centos/7/cloud/x86_64/openstack-mitaka/

You can copy the files from these locations, create a local repository and try to perform an offline install that way.

Note: it would be possible to install Kilo, but it is strongly recommended to use a newer version.

edit flag offensive delete link more

Comments

Thank you @gbraad .. I have done it using following link.

http://www.unixmen.com/setup-local-yum-repository-centos-7/ (http://www.unixmen.com/setup-local-yu...)

pandia gravatar imagepandia ( 2016-05-23 03:42:06 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-05-11 02:17:12 -0600

Seen: 2,085 times

Last updated: May 12 '16