Ask Your Question

"NO route to host" after installing TripleO Virtual Environment

asked 2016-05-11 01:43:53 -0500

Jerry Chen gravatar image

Dear All,

I have followed the instruction to install virtual environment on Cent OS 7. ( (

The problem is, after finishing "instack-virt-setup" and make instack vm up and running, I CANNOT ssh to the vm due to "No route to host", while the state of instack vm is RUNNING.

Then I tried to reboot the Cent OS. But much worse is that instack vm becomes 'shut off' state...

Anyone who met with this issue have found any workaround? Or it is due to known bug of the latest TripleO?

Thank you!

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2016-05-16 04:41:07 -0500

dbaxps gravatar image

updated 2016-05-16 04:43:23 -0500

See "Deploying OpenStack on just one hosted server" :-
It was written to be understood by everybody.

edit flag offensive delete link more

answered 2016-05-12 02:27:41 -0500

gbraad gravatar image

updated 2016-05-16 22:29:13 -0500

Although you can try to debug this, I suggest you to try installing with the TripleO quickstart scripts. This uses a prebuilt image for the undercloud which simplifies the whole process (and will eventually replace instack).

More information can be found at:

$ export VIRTHOST='[host of machine you target]' $ curl -O $ sudo bash --install-deps

After which you can do:

$ bash $VIRTHOST #will deploy the undercloud $ ssh -F ~/.quickstart/ssh.config.ansible undercloud

and follow the instructions for doing the deployment of the overcloud. Or you can:

$ bash --tags all $VIRTHOST # will deploy overcloud

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-05-11 01:43:53 -0500

Seen: 199 times

Last updated: May 16 '16