cloudkitty (kilo) installation error

asked 2016-05-10 07:44:13 -0600

daryana gravatar image

updated 2016-05-10 07:50:23 -0600

I try to install cloudkitty in openstack kilo release by packages(I have 2 nodes, 1 controller and 1 compute). I follow these steps :

  1. mk dire: /etc/yum.repos.d/cloudkitty.repo

    name=CloudKitty repository (Kilo)
  2. yum install cloudkitty-api cloudkitty-processor

  3. change /etc/cloudkitty/cloudkitty.conf

    verbose = True
    log_dir = /var/log/cloudkitty
    rabbit_userid = guest
    rabbit_password = guest
    rabbit_hosts = controller:5672
    username = cloudkitty
    password = cloudkitty
    tenant = services
    region = RegionOne
    url = http://controller:5000/v2.0
    username = cloudkitty
    password = cloudkitty
    project_name = services
    region = RegionOne
    auth_url = http://controller:5000/v2.0
    auth_plugin = password
    connection = mysql://cloudkitty:cloudkitty@controller/cloudkitty
    username = admin
    password = adminpass from keystonerc_admin
    tenant = admin
    region = RegionOne
    url = http://controller:5000/v2.0
    username = cloudkitty
    password = cloudkitty 
    tenant = services
    region = RegionOne
    url = http://controller:5000
  4. Setup the database and storage backend:

     mysql -uroot -p
     CREATE DATABASE cloudkitty;
     GRANT ALL PRIVILEGES ON cloudkitty.* TO 'cloudkitty'@'controller' IDENTIFIED BY 'cloudkitty';
  5. cloudkitty-dbsync upgrade & cloudkitty-storage-init

  6. openstack user create --password-prompt cloudkitty (password: cloudkitty) & openstack role add --project services --user cloudkitty admin & openstack service create --name cloudkitty --description "Rating" rating & openstack role add --project admin --user cloudkitty rating &

    openstack endpoint create \ --publicurl http://controller:8777 \ --internalurl http://controller:8777 \ --adminurl http://controller:8777 \ --region RegionOne \ rating

but when I run every cloudkitty command I get this error and I think it cant authorized to keystone:

Not Found (HTTP 404) (Request-ID: req-ad902ad7-3d02-4c7b-9055-5156f72036d9)

I dont know where I mistake.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2016-05-11 02:07:24 -0600

shashidhar gravatar image

Looks like authentication with Keystone is not happening. Could you check if "keystone" services and "nova" services are running properly in your system.

edit flag offensive delete link more


you are right, but it is just for cloudkitty, other services work corroctly. For example, "keystone tenant-list" and "nova service-list" give corroct results.

daryana gravatar imagedaryana ( 2016-05-11 05:04:52 -0600 )edit

answered 2016-05-11 05:23:51 -0600

daryana gravatar image

updated 2016-05-14 00:09:29 -0600

I have the following warning in cloudkitty/api.log : [-] serving on, view at
2016-05-11 03:27:14.463 22472 WARNING oslo_config.cfg [-] Option "username" from group "keystone_authtoken" is   deprecated. Use option "username" from group "keystone_authtoken".
2016-05-11 03:27:14.464 22472 WARNING keystonemiddleware.auth_token [-] Configuring auth_uri to point to the public identity endpoint is required; clients may not be able to authenticate against an admin endpoint

maybe these warnings cause the problem!!! But how can I solved them?

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-05-10 07:44:13 -0600

Seen: 410 times

Last updated: May 14 '16