Ask Your Question
1

Got error when perform havana install.

asked 2013-12-20 03:39:57 -0500

anonymous user

Anonymous

updated 2014-01-22 15:12:29 -0500

Evgeny gravatar image

Hi, I tried install Havana via “packstack --allinone” on CentOS 6.4. However got error as below. Anyone have idea about it? Thanks.

RROR : Error appeared during Puppet run: <ip address="">_neutron.pp Error: Parameter name failed on Package[dnsmasq]: Name must be a String not Array at /var/tmp/packstack/d97256ccb1004381b7af5108ffa3111c/modules/neutron/manifests/agents/dhcp.pp:64 You will find full trace in log /var/tmp/packstack/20131220-171340-l0iSPU/manifests/<ip address="">_neutron.pp.log</ip></ip>

Warning: Could not retrieve fact fqdn Warning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults Notice: Compiled catalog for controller in environment production in 1.13 seconds Error: Parameter name failed on Package[dnsmasq]: Name must be a String not Array at /var/tmp/packstack/d97256ccb100438 1b7af5108ffa3111c/modules/neutron/manifests/agents/dhcp.pp:64 Wrapped exception: Name must be a String not Array

edit retag flag offensive close merge delete

Comments

even i am facing the same issue. any feedback will be very helpful.

bubuli gravatar imagebubuli ( 2013-12-20 04:59:39 -0500 )edit

Yesterday everything worked. And today, no.

dubrsl gravatar imagedubrsl ( 2013-12-20 05:23:54 -0500 )edit

Same problem here

Romain gravatar imageRomain ( 2013-12-20 06:25:55 -0500 )edit

And me too - the same problem.

Alan Pfeiffer-Traum gravatar imageAlan Pfeiffer-Traum ( 2013-12-20 06:33:15 -0500 )edit

I also meet this problem today. I just apply the latest change of the file /usr/lib/python2.6/site-packages/packstack/puppet/modules/neutron/manifests/agents/dhcp.pp: https://github.com/stackforge/puppet-neutron/blob/2ccd0b77eba453df0bd44065127a281963b134a5/manifests/agents/dhcp.pp. Then it is passed.

Euler gravatar imageEuler ( 2013-12-20 07:57:41 -0500 )edit

2 answers

Sort by » oldest newest most voted
3

answered 2013-12-20 06:42:58 -0500

dubrsl gravatar image

It seems the problem because of the new puppet

Try

yum downgrade puppet-3.3.2-1.el6.noarch
edit flag offensive delete link more

Comments

Works for me, except that I did not downgrade but install it. Thanks!

Romain gravatar imageRomain ( 2013-12-20 07:36:43 -0500 )edit

Thanks, packstack progresses further along now. However, later it stubs its toe trying to install openstack-ceilometer-api which requires python-sphinx. python-sphinx is not in epel for rhel6. (edit) No problems now. I see that python-sphinx moved to the "server-optional" channel in rhel6.

Alan Pfeiffer-Traum gravatar imageAlan Pfeiffer-Traum ( 2013-12-20 07:37:52 -0500 )edit

It works for me. Thanks.

l-39 gravatar imagel-39 ( 2013-12-20 21:20:18 -0500 )edit
0

answered 2013-12-20 08:17:05 -0500

updated 2013-12-20 08:20:28 -0500

packstack will be updated shortly to cater for the new puppet.

puppetlabs released 3.4 to their repos a few hours ago triggering the issue.

https://bugzilla.redhat.com/1045283

edit flag offensive delete link more

Comments

Thanks for this information!

Euler gravatar imageEuler ( 2013-12-20 09:36:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-20 03:39:57 -0500

Seen: 691 times

Last updated: Dec 20 '13