Ask Your Question
0

dashboard error 500 on install

asked 2016-05-08 03:44:38 -0500

wsilence gravatar image

updated 2016-05-09 18:06:10 -0500

Please, help with installation dashboard on opensuse. Follow the instructions in http://docs.openstack.org/mitaka/install-guide-obs/horizon-install.html (http://docs.openstack.org/mitaka/inst...) and got error 500 then try open dashboard.

When comment in settings.py lines 379

#from openstack_auth import policy
#POLICY_CHECK_FUNCTION = policy.check

and 399

#from openstack_auth import utils as auth_utils
#auth_utils.patch_middleware_get_user()

I can start from manage.py runserver. Butn not from apache.


django version =1.9.2

[Sun May 08 08:10:09.295384 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168] mod_wsgi (pid=2016): Target WSGI script '/srv/www/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi' cannot be loaded as Python module.
[Sun May 08 08:10:09.295417 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168] mod_wsgi (pid=2016): Exception occurred processing WSGI script '/srv/www/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi'.
[Sun May 08 08:10:09.295437 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168] Traceback (most recent call last):
[Sun May 08 08:10:09.295451 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]   File "/srv/www/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi", line 14, in <module>
[Sun May 08 08:10:09.295499 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]     application = get_wsgi_application()
[Sun May 08 08:10:09.295508 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]   File "/usr/lib/python2.7/site-packages/django/core/wsgi.py", line 13, in get_wsgi_application
[Sun May 08 08:10:09.295537 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]     django.setup()
[Sun May 08 08:10:09.295545 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]   File "/usr/lib/python2.7/site-packages/django/__init__.py", line 17, in setup
[Sun May 08 08:10:09.295570 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]     configure_logging(settings.LOGGING_CONFIG, settings.LOGGING)
[Sun May 08 08:10:09.295576 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]   File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 55, in __getattr__
[Sun May 08 08:10:09.295632 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]     self._setup(name)
[Sun May 08 08:10:09.295639 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]   File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 43, in _setup
[Sun May 08 08:10:09.295649 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]     self._wrapped = Settings(settings_module)
[Sun May 08 08:10:09.295653 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]   File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 99, in __init__
[Sun May 08 08:10:09.295660 2016] [wsgi:error] [pid 2016] [client 127.0.0.1:45168]     mod = importlib.import_module(self.SETTINGS_MODULE)
[Sun May 08 08:10:09.295664 2016] [wsgi:error] [pid 2016] [client 127.0.0 ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-11-13 12:18:52 -0500

Hossein gravatar image

I had an issue, not sure if similar to yours. But I fixed it by looking at :/var/log/apache2/horizon_error.log

It has this error: /usr/local/lib/python2.7/dist-packages/django/http/request.py", line 102, in get_host DisallowedHost: Invalid HTTP_HOST header: '192.168.x.x' You may need to add u'192.168.x.x' to ALLOWED_HOSTS.

It was fixed by adding my HOST IP address inside request.py file

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-05-08 03:44:38 -0500

Seen: 949 times

Last updated: May 09 '16