Ask Your Question
0

Bad response code while validating token: 400

asked 2016-05-07 17:43:50 -0600

PedroStefano gravatar image

Fiz um deploy usando a versão mitaka mas estou tendo erro para utilizar os comandos do neutron pelo horizon eu consigo criar as redes e usar, mas quando vou criar uma instancia da erro. Acredito que seja por causa de não conseguir utilizar os comandos de rede. Tenho 3 nodes, 1 controller, 1 nova e 1 neutron. Segue logs e configurações definidas nos arquivos.

Se alguém puder me ajudar, agradeço


I made a deployment using mitaka version but am having error to use the neutron commands the horizon I can create networks and use, but when I create an instance of the error. I believe it is because of not being able to use the network commands. I have 3 nodes, 1 controller, 1 new and 1 neutron. The following logs and set the file settings.

If anyone can help me, thank you

Controller

/etc/neutron/neutron.conf

[keystone_authtoken]

auth_uri = http://controller:5000/v3
auth_url = http://controller:35357/v3
memcached_servers = controller:11211
auth_type = password
project_domain_name = default
user_domain_name = default
project_name = service
user-name = neutron
password = p3sneutron


[nova]
auth_url = http://controller:35357/v3
auth_type = password
project_domain_name = default
user_domain_name = default
region_name = RegionOne
project_name = service
user_name = nova
password = p3snova

/etc/nova/nova.conf

[keystone_authtoken]
auth_uri = http://controller:5000/v3
auth_url = http://controller:35357/v3
memcached_servers = controller:11211
auth_type = password
project_domain_name = default
user_domain_name = default
project_name = service
username = nova
password = p3snova


[neutron]

url = http://controller:9696
auth_url = http://controller:35357/v3
auth_type = password
project_domain_name = default
user_domain_name = default
region_name = RegionOne
project_name = service
username = neutron
password = p3sneutron

service_metadata_proxy = True
metadata_proxy_shared_secret = p3smetadata

openstack network list

HttpException: Service Unavailable, 503 Service Unavailable

The server is currently unavailable. Please try again at a later time.

openstack network list --debug

START with options: ['network', 'list', '--debug']
options: Namespace(access_token_endpoint='', auth_type='', auth_url='http://controller:35357/v3', cacert='', client_id='', client_secret='***', cloud='', debug=True, default_domain='default', deferred_help=False, domain_id='', domain_name='', endpoint='', identity_provider='', identity_provider_url='', insecure=None, interface='', log_file=None, os_compute_api_version='', os_dns_api_version='2', os_identity_api_version='3', os_image_api_version='2', os_network_api_version='', os_object_api_version='', os_orchestration_api_version='1', os_project_id=None, os_project_name=None, os_volume_api_version='', password='***', profile=None, project_domain_id='', project_domain_name='default', project_id='', project_name='admin', protocol='', region_name='', scope='', service_provider_endpoint='', timing=False, token='***', trust_id='', url='', user_domain_id='', user_domain_name='default', user_id='', username='admin', verbose_level=3, verify=None)
defaults: {u'auth_type': 'password', u'compute_api_version': u'2', 'key': None, u'database_api_version': u'1.0', 'api_timeout': None, u'baremetal_api_version': u'1', u'image_api_version': u'2', 'cacert': None, u'image_api_use_tasks': False, u'floating_ip_source': u'neutron', u'orchestration_api_version': u'1', u'interface': None, u'network_api_version': u'2', u'image_format': u'qcow2', u'key_manager_api_version': u'v1', u'metering_api_version': u'2', 'verify': True, u'identity_api_version': u'2.0', u'volume_api_version': u'2', 'cert': None, u'secgroup_source': u'neutron', u'container_api_version': u'1', u'dns_api_version': u'2', u'object_store_api_version': u'1', u'disable_vendor_agent': {}}
cloud cfg: {'auth_type': 'password', u'compute_api_version': u'2', 'key': None, u'database_api_version': u'1.0', 'timing': False, u'network_api_version': u'2', u'image_format': u'qcow2', u'image_api_version': '2', 'verify': True, u'dns_api_version': '2', u'object_store_api_version': u'1', 'verbose_level': 3, 'region_name': '', 'api_timeout': None, u'baremetal_api_version': u'1', 'auth': {'username': 'admin', 'project_name': 'admin', 'user_domain_name': 'default', 'auth_url': 'http://controller ...
(more)
edit retag flag offensive close merge delete

Comments

Same issue. Did you find where the problem is?

Olorim gravatar imageOlorim ( 2016-06-16 04:19:14 -0600 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2016-09-19 08:55:12 -0600

I also had same issue. In my case, the root cause is missing role of neutron.

When I create neutron user, I lost next command.

openstack role add --project service --user neutron admin

I wish this will be your help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-05-07 17:43:50 -0600

Seen: 566 times

Last updated: May 07 '16