Ask Your Question
4

keystone- Could not determine a suitable URL for the plugin using devstack

asked 2016-05-04 09:39:57 -0600

ashu gravatar image
     Hi Team 


    I'm trying to install single node openstack controller node on x86 using devstack(master branch) and I'm getting below errors..

    2016-05-03 13:25:17.364 | +./stack.sh:main:1033                      create_keystone_accounts
    2016-05-03 13:25:17.371 | +lib/keystone:create_keystone_accounts:368  local admin_project
    2016-05-03 13:25:17.378 | ++lib/keystone:create_keystone_accounts:369  openstack project show admin -f value -c id
    2016-05-03 13:25:19.047 | Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
    2016-05-03 13:25:19.047 | Could not determine a suitable URL for the plugin
    2016-05-03 13:25:19.077 | +lib/keystone:create_keystone_accounts:369  admin_project=
    2016-05-03 13:25:19.084 | +lib/keystone:create_keystone_accounts:1   exit_trap
    2016-05-03 13:25:19.091 | +./stack.sh:exit_trap:474                  local r=1
    2016-05-03 13:25:19.099 | ++./stack.sh:exit_trap:475                  jobs -p
    2016-05-03 13:25:19.107 | +./stack.sh:exit_trap:475                  jobs=
    2016-05-03 13:25:19.114 | +./stack.sh:exit_trap:478                  [[ -n '' ]]
    2016-05-03 13:25:19.121 | +./stack.sh:exit_trap:484                  kill_spinner
    2016-05-03 13:25:19.131 | +./stack.sh:kill_spinner:370               '[' '!' -z '' ']'
    2016-05-03 13:25:19.138 | +./stack.sh:exit_trap:486                  [[ 1 -ne 0 ]]
    2016-05-03 13:25:19.145 | +./stack.sh:exit_trap:487                  echo 'Error on exit'
    2016-05-03 13:25:19.145 | Error on exit
    2016-05-03 13:25:19.151 | +./stack.sh:exit_trap:488                  generate-subunit 1462281706 213 fail
    2016-05-03 13:25:19.438 | +./stack.sh:exit_trap:489                  [[ -z /home/contrail/devstack/log ]]
    2016-05-03 13:25:19.445 | +./stack.sh:exit_trap:492                  /home/contrail/devstack/tools/worlddump.py -d /home/contrail/devstack/log
    2016-05-03 13:25:20.188 | +./stack.sh:exit_trap:498                  exit 1

    My localrc file is as below..
    STACK_DIR=$(cd $(dirname $0) && pwd)

    LOG_DIR=$STACK_DIR/log/screens
    LOG=True
    DEBUG=True
    LOGFILE=$STACK_DIR/log/stack.log
    LOGDAYS=1
    SCREEN_LOGDIR=$LOG_DIR

    disable_service n-net
    enable_service q-svc
    enable_service q-meta
    enable_service neutron

    # not used by contrail
    disable_service q-agt
    disable_service q-dhcp
    disable_service q-l3

    DATABASE_PASSWORD=contrail123
    RABBIT_PASSWORD=contrail123
    SERVICE_TOKEN=contrail123
    SERVICE_PASSWORD=contrail123
    ADMIN_PASSWORD=contrail123

    Q_PLUGIN=opencontrail
    PHYSICAL_INTERFACE=eth0

    # proto for openstack bits. Use HTTPS if git is firewalled
    GIT_BASE=https://git.openstack.org

    # opencontrail nova plugin
    # NOVA_VIF_DRIVER=nova_contrail_vif.contrailvif.VRouterVIFDriver

    Q_PLUGIN_CLASS=neutron_plugin_contrail.plugins.opencontrail.contrail_plugin.NeutronPluginContrailCoreV2

Please help me regarding this.
-Thanks
Abhishek Jain
VVDN Technologies
edit retag flag offensive close merge delete

Comments

Hey did manage to find a way around this? I am facing the same problem.

xerocool gravatar imagexerocool ( 2016-06-07 04:37:02 -0600 )edit

I also face the issue. BTW did you try the ./clean.sh and then ./stack.sh ? For me the issue still exists even after doing this step There is this linked question also https://ask.openstack.org/en/question/90926/devstack-install-fails/ (https://ask.openstack.org/en/question...)

RameshD gravatar imageRameshD ( 2016-06-16 08:42:17 -0600 )edit

https://www.linux.com/learn/how-test-drive-openstack (https://www.linux.com/learn/how-test-...) The solution mentioned here also does not work

RameshD gravatar imageRameshD ( 2016-06-16 10:20:42 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
3

answered 2016-06-30 02:32:20 -0600

jian-zhang8 gravatar image

I got the same error. And i fixed it by adding my local ip address into no_proxy.

edit flag offensive delete link more

Comments

Tried adding my local ip address to the no_proxy environment variable and it still did not work.

profhaury gravatar imageprofhaury ( 2016-07-14 14:25:12 -0600 )edit

I got the same issue and including my local ip address into variable no_proxy has fixed this issue. Thanks a lot for your information no_proxy=xxx.xxx.xxx.xxx ; export no_proxy ; Then, I just run the script again: ./stack

:-)

Vinicius gravatar imageVinicius ( 2017-03-07 16:05:21 -0600 )edit
2

answered 2016-07-02 02:33:52 -0600

Sarbajit gravatar image

In my case the issue was with wrong requirements. After getting this error, I checked logs/key.log and it had below exception -

ContextualVersionConflict: (python-keystoneclient 3.1.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('python-keystoneclient!=1.8.0,!=2.1.0,<3.0.0,>=1.6.0'), set(['keystone']))

So, the python-keystoneclient version was mismatched. I used a stable branch in stackrc file -

REQUIREMENTS_BRANCH=${REQUIREMENTS_BRANCH:-stable/mitaka}

but after the error when I checked git status inside requirements directory, it showed origin/master as current branch. It should have been stable/mitaka.

I had to delete the requirements directory to allow the git clone to happen again when doing ./stack.sh. That fixed the issue.

edit flag offensive delete link more

Comments

Thanks, this solved my problem.

lvdongbing gravatar imagelvdongbing ( 2016-10-26 20:03:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-05-04 09:39:57 -0600

Seen: 10,669 times

Last updated: Jul 02 '16