Ask Your Question
0

Neutron agent-list missing linux bridge agent

asked 2016-05-03 20:21:17 -0500

D3LTA9 gravatar image

updated 2016-05-03 20:24:18 -0500

After install neutron and using option 1 provider networks when I run a agent-list command I only see dhcp and metadata agents running on my controller node and not the linux bridge agent that I should see as well on both my controller and compute node. I have tried restarting the linuxbridge agent and it is definitely running, I have also followed the installation guide on configuration.

The only issue I can think of is:

In the [linux_bridge] section, map the provider virtual network to the provider physical network interface: Here I have put

"physical_interface_mappings = provider:Provider_Network"

I was not 100% sure what to put for this as I am running a logical network for the provider network on 192.168.2.0 and running physical for my management network on 192.168.1.0.

The name of the virtual machine port group is "Provider_Network" and both my compute and controller nodes are attached to this port group and I have a vyos virtual router also connected to the Provider_Network port group which provides internet access to the 192.168.2.0 network.

I also have another "VM Network" port group which handles the management traffic, all nodes are connected to, and is connected to my physical 192.168.1.0 network and my Asus router (192.168.1.1)

This area was the only part I really was not sure about during my initial environment configuration, have I completely messed up my basic network environment configuration? I still do not completely understand the network layout part of the install guide here:

http://docs.openstack.org/mitaka/install-guide-ubuntu/environment-networking.html (http://docs.openstack.org/mitaka/inst...)

In a basic home lab environment with only one publicly routable IP that via NAT on my physical router provides internet access to my private address space network, how do you also have a second direct connection to a publicly routable IP?

Thanks again for any help!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-05-03 20:49:31 -0500

Carrot gravatar image

1) Check log: /var/log/neutron/neutron-plugin-linuxbridge-agent.log

2) replace config like this.

  "physical_interface_mappings = provider:eth0"

If you use eth1 as external network, change eth0 to eth1.

edit flag offensive delete link more

Comments

thank you! of course, so stupid of me, it will be the name of the interface the provider network should be running on. Clearly been staring at a CLI too long its melting my brain haha.

D3LTA9 gravatar imageD3LTA9 ( 2016-05-03 21:36:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-05-03 20:21:17 -0500

Seen: 1,852 times

Last updated: May 03 '16