Ask Your Question

openstack-db --update error when upgrading from Liberty to Mitaka

asked 2016-05-03 19:39:50 -0500

todotani gravatar image

I'm trying to upgrade Liberty to Mitaka and having a problem to upgrading db. If anyone can advice me to workaround this error, I'm very appreciated.

I'm following procedure shown in this link: (RDO - Upgrading from Liberty to Mitaka)

Procedure is the followings:

1) yum install (

2) yum upgrade mariadb mariadb-server

3) yum install python2-PyMySQL

4) (modify keystone.conf according to installation document of Mitaka)

5) openstack-db --service keystone --update ==> got the following error

Traceback (most recent call last):
  File "/usr/bin/keystone-manage", line 6, in <module>
    from keystone.cmd.manage import main
  File "/usr/lib/python2.7/site-packages/keystone/cmd/", line 31, in <module>
    from keystone.cmd import cli
  File "/usr/lib/python2.7/site-packages/keystone/cmd/", line 31, in <module>
    from keystone.common import sql
  File "/usr/lib/python2.7/site-packages/keystone/common/sql/", line 15, in <module>
    from keystone.common.sql.core import *  # noqa
  File "/usr/lib/python2.7/site-packages/keystone/common/sql/", line 24, in <module>
    from oslo_db import exception as db_exception
  File "/usr/lib/python2.7/site-packages/oslo_db/", line 143, in <module>
    class DBInvalidUnicodeParameter(Exception):
  File "/usr/lib/python2.7/site-packages/oslo_db/", line 151, in DBInvalidUnicodeParameter
AttributeError: 'module' object has no attribute 'removed_property'
Can't determine the existing sync level.
Please ensure the database is running and already initialised.

My locale is "en_US.UTF-8" and my controller node is running with CentOS-7.2. MariaDB is running and initialized when I installed Liberty.


edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2016-05-04 00:03:23 -0500

todotani gravatar image

I found solution.

Once remove openstack-utils (from Liberty repository) including dependencies and then reinstall from Mitaka repository make successful db-update.

The followings worked for me.

yum remove openstack-utils
yum install openstack-utils
openstack-db --service keystone --update

Option "verbose" from group "DEFAULT" is deprecated for removal. Its value may be silently ignored in the future.
Option "verbose" from group "DEFAULT" is deprecated for removal. Its value may be silently ignored in the future.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-05-03 19:39:50 -0500

Seen: 671 times

Last updated: May 04 '16