Mirantis Fuel 8.0 VirtualBox DNS nameserver configuration for nodes

asked 2016-05-03 16:36:38 -0500

medington-cb gravatar image

updated 2016-05-04 12:54:35 -0500

I have used the Mirantis OpenStack VirtualBox install scripts successfully on OS X and Window 10.

However, I have one issue that I need some help resolving. When I initially setup the environment using the scripts I did so on my home network which uses 192.168.22.0/24 subnet and it's nameserver is 192.168.22.1. After deploying the default 4 nodes (8GB config) I see this address listed as an entry in the /etc/resolv.conf file on each VM / node that is running under VirtualBox.

The problem I have is that when I bring my MacBook to work this entry becomes invalid and causes failures in the OpenStack environment (various errors show up, all name resolution related). I've worked around this by editing the /etc/resolv.conf entries to use 8.8.8.8 instead and then restarting nova-compute as needed. However this solution does not "stick". If I reboot any of the VirtualBox VMs the /etc/resolv.conf nameserver entries revert to using 192.168.22.1. Can anyone tell me where that happens and I how can "fix" it?

I also found this IP was being used in the Fuel UI for "Host OS DNS Servers" (on Network Settings | Other) and I changed it there to 8.8.8.8 there, so I don't think that is where it originates from for the nodes themselves.

Here is the contents of my current /etc/resolv.conf from my Fuel VM:

search domain.tld
domain domain.tld
nameserver 10.20.0.2
nameserver 8.8.8.8

After I reboot that VM (or any of the others) that last line changes back to 192.168.22.1 and my environment starts running into errors.

edit retag flag offensive close merge delete