Ask Your Question
1

hypervisor_type = QEMU, but virt_type=kvm

asked 2016-05-03 10:55:41 -0600

herrsergio gravatar image

updated 2016-05-03 12:07:48 -0600

larsks gravatar image

Hi everybody,

I have the following question, I have configured in the computes to use kvm (/etc/nova/nova-compute.conf):

virt_type=kvm

But when I execute the following command, the output says it is using QEMU:

# nova hypervisor-show 5 | grep hypervisor_type
| hypervisor_type           | QEMU

OpenStack version in Kilo.

Thanks in advance.

* Update in response to larsks *

I haven't changed anything since the installation and the start of the services.

# virsh capabilities | grep kvm
<baselabel type='kvm'>+0:+0</baselabel>
<domain type='kvm'>
<domain type='kvm'>

But I found something:

#  virt-host-validate
QEMU: Checking for hardware virtualization                                 : PASS
QEMU: Checking for device /dev/kvm                                         : PASS
QEMU: Checking for device /dev/vhost-net                                   : PASS
QEMU: Checking for device /dev/net/tun                                     : PASS
LXC: Checking for Linux >= 2.6.26                                         : PASS

And when I get the "virsh dumpxml" of an instance:

<domain type='kvm' id='44'>
....
<emulator>/usr/bin/qemu-system-x86_64</emulator>

Is that the problem ? If yes, how can I force it to use qemu-kvm.

edit retag flag offensive close merge delete

Comments

Did you restart nova-compute after making this change? Does virsh capabilities show a kvm domain for the x86_64 arch?

larsks gravatar imagelarsks ( 2016-05-03 11:13:46 -0600 )edit

I will reply below, because the comment doesn't fit here.

herrsergio gravatar imageherrsergio ( 2016-05-03 11:44:49 -0600 )edit

I fixed that for you.

larsks gravatar imagelarsks ( 2016-05-03 12:08:27 -0600 )edit

Thank you.

herrsergio gravatar imageherrsergio ( 2016-05-03 12:57:13 -0600 )edit

4 answers

Sort by ยป oldest newest most voted
0

answered 2018-07-18 13:30:16 -0600

After much experimentation and reading of documentation, I think that the answer to the problem is that when you are using nested virtualisation, your hypervisor type always appears as QEMU. However, you can confirm that you are using nested KVM on your compute nodes, by looking at the process line (ps -ef|grep qemu) of your created servers. It will look something like this:

/usr/libexec/qemu-kvm -name guest=instance-00000032,debug-threads=on -S -object secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-1-instance-00000032/master-key.aes -machine pc-i440fx-rhel7.5.0,accel=kvm

(note the bold text) which shows that KVM acceleration is in use. Also, you'll be able to tell because your servers will be approximately a million times faster... :)

edit flag offensive delete link more
0

answered 2018-06-16 15:18:51 -0600

XP_2600 gravatar image

I have the same issue, i am using queens, /etc/nova/nova.conf shows: [libvirt] vif_driver=nova.virt.libvirt.vif.LibvirtGenericVIFDriver virt_type=kvm

but when i run nova hypervisor-show

i get hypervisor_type | QEMU

edit flag offensive delete link more
2

answered 2016-05-03 20:35:12 -0600

Carrot gravatar image

'ps' command in your compute node.

ps axfu | grep -e qemu -e kvm

If show like this 'qemu-system-x86_64 -machine accel=kvm:tcg' ,KVM work well.

Please refer this. https://bugs.launchpad.net/nova/+bug/...

edit flag offensive delete link more
0

answered 2016-05-03 11:36:52 -0600

hkominos gravatar image

Also in Fuel-Kilo nova is managed my 2 files instead of one. One is nova.conf and the other is called nova-compute.conf. They are in the same place and they must both be changed. Type ps -ax |grep nova on the compute host in you will see in the config-files option where is the second file. Could be the issue if you have Fuel

edit flag offensive delete link more

Comments

Thanks, I don't use Fuel.

herrsergio gravatar imageherrsergio ( 2016-05-03 11:45:41 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-05-03 10:55:41 -0600

Seen: 1,696 times

Last updated: May 03 '16