Ask Your Question
0

can't restart apache2 with keystone

asked 2016-05-02 08:34:43 -0500

anonymous user

Anonymous

updated 2016-05-02 10:36:35 -0500

larsks gravatar image

HI, when I restart the keystone, the 5000 port be listen by python and I didn’t restart the apache2 , i have this msg error any help PLZ ? :

root@controller:/usr/share/apache2/error# service apache2 restart
 * Restarting web server apache2                                                                                                         [ OK ]
root@controller:/usr/share/apache2/error# service keystone restart
stop: Unknown instance:
keystone start/running, process 21705
root@controller:/usr/share/apache2/error# netstat -lp | grep :5000
tcp6       0      0 [::]:5000               [::]:*                  LISTEN      21532/apache2
root@controller:/usr/share/apache2/error# service apache2 restart
 * Restarting web server apache2                                                                                                                (98)Address already in use: AH00072: make_sock: could not bind to address [::]:5000
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:5000
no listening sockets available, shutting down
AH00015: Unable to open logs
Action 'start' failed.
edit retag flag offensive close merge delete

Comments

Which version of OpenStack are you running? In recent versions, keystone is typically recommended to be run as part of apache2. So, you want to do "service keystone stop" and then just restart apache2. And then check if you can perform keystone commands.

ypraveen gravatar imageypraveen ( 2016-05-02 11:45:47 -0500 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2016-05-02 20:04:44 -0500

Carrot gravatar image

I think you run keystone and Apache both.

    service keystone stop
    service apache2 restart

If you want to do keystone as standalone mode, remove the keystone configure in apache.conf

   rm /etc/apache2/sites-available/wsgi-keystone.conf
edit flag offensive delete link more

Comments

still there is no way to start both httpd and keystone to start simultaneously. if we want any one, then we need to stop other one service. hi team , is there no way to start both process.

hk gravatar imagehk ( 2016-06-23 01:53:15 -0500 )edit
0

answered 2016-06-23 14:22:59 -0500

hk gravatar image

updated 2016-06-23 14:23:40 -0500

In some case of openstack gives this error because port describe in file "/etc/httpd/conf.d/wsgi-keystone.conf" is same as keystone endpoint URL port. so it conflict and both keystone and httpd service not start simultaneously.

for its if you change port of keystone endpoint then you would require to change in lots of other openstack service config file

so change port 5000 to 5001 and 35357 to 35358 in file "/etc/httpd/conf.d/wsgi-keystone.conf".and reboot. then both service will work simultaneously in above file if you set to port 80 then it will conflict with "/etc/httpd/conf/httpd.conf". so kindly change as above then it work work.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-05-02 08:34:43 -0500

Seen: 2,470 times

Last updated: Jun 23 '16