Ask Your Question
0

Keystone: As the demo user, request an authentication token error

asked 2016-05-01 23:59:32 -0500

D3LTA9 gravatar image

updated 2016-05-02 01:12:43 -0500

Yet another issue attempting to follow the installation guide for ubuntu 14.04 http://docs.openstack.org/mitaka/install-guide-ubuntu/index.html (http://docs.openstack.org/mitaka/inst...)

Installing keystone was working up to the verify operation section step 3 - request authentication token as admin user. -This works fine.

I try to do the same as the demo user in step 4 and I get the following error:

"Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL. Internal Server Error (HTTP 500)"

Someone seemed to have the same issue here: http://askubuntu.com/questions/720967/internal-server-error-http-500-when-issuing-an-authentication-token-for-openst?newreg=232dfbd7659c418fb8fe75433e540505 (http://askubuntu.com/questions/720967...)

The solution in this question was: to solve this, I changed the LOCAL_PATH value in local_settings.py (installing Liberty on Ubuntu Server 14.04, I found it in /etc/openstack-dashboard/)

so I changed LOCAL_PATH = os.path.dirnames(os.path.abspath(__file__)) to LOCAL_PATH = '/tmp'

However, this confuses me as the guide does not cover installing the dashboard until much later on after imaging, compute and networking, so obviously I dont have a /etc/openstack-dashboard/ folder, nor a local_settings.py file.

Can anyone point me in the right direction here? Should I just attempt to install dashboard before everything else and apply this fix? This does not seem like it would work or a very logical solution to me -the guide clearly has ordered the installation of services in this manner due to the operation and interaction of the services. In fact, I am almost 100% sure this wouldnt work as dashboard/horizon requires the other services to be functional before installation.

Thanks for any help in advance.

EDIT - actually, if I load my demo user environment variables and attempt anything I get this error - like a simple openstack user list command. Then it works fine after I source admin credentials by running . admin-openrc

EDIT 2 - is it because I am using API V3 and should be using V2?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-05-04 20:39:37 -0500

D3LTA9 gravatar image

My own fault, I made a mistake when I disabled the temporary authentication token mechanism.

edit flag offensive delete link more
0

answered 2016-05-02 03:37:00 -0500

dbaxps gravatar image

Assigning role admin to admin on project demo you request token scope "demo" :-

# . keystonerc_admin
# curl -i  -H "Content-Type: application/json" -d \
' { "auth":
   { "identity":
    { "methods": ["password"], "password":
     { "user":
      { "name": "admin", "domain":
        { "id": "default" }, "password": "7049f834927e4468" }
      }
     },
  "scope":
{ "project":
  { "name": "demo", "domain":
    { "id": "default" }
     }
      }
    }
}'  http://192.169.142.127:5000/v3/auth/tokens ; echo
edit flag offensive delete link more

Comments

Thanks for the help but as it turns out I had messed up when I disabled the temporary authentication token mechanism. Working now.

D3LTA9 gravatar imageD3LTA9 ( 2016-05-04 20:39:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-05-01 23:59:32 -0500

Seen: 717 times

Last updated: May 04 '16