configuring public network

asked 2016-05-01 20:41:46 -0500

melbogia gravatar image

Hiya, I installed fuel on virtual box running on my home computer. Out of the box the public network is set to

172.16.0.0/24
IP range: 172.16.0.2 - 172.16.0.126
gateway: 172.16.0.1

Neutron L3 floating ip range: 172.16.0.130 - 172.16.0.254

In this case the connectivity check is successful but I want the public and floating ip addresses to be on my home LAN so I can get to the VMs from other computers. The home LAN is 192.168.1.0/24. When I change the above to the following, the check fails.

192.168.1.0/24
IP range: 192.168.1.200 - 192.168.1.235
gateway: 192.168.1.1

Neutron L3 floating ip range: 192.168.1.236 - 192.168.1.254

The error is:

Verification failed.
Repo availability verification using public network failed on following nodes Untitled (49:e5).
Following repos are not available - http://archive.ubuntu.com/ubuntu/, http://mirror.fuel-infra.org/mos-repos/ubuntu/8.0/
. Check your public network settings and availability of the repositories from public network. Please examine nailgun and astute logs for additional details.

I don't understand why the check is failing. Shouldn't it be able to get to the internet when the public network is set use IP addresses that are in the home LAN? I don't see anything obvious on the controller (49:e5) node logs.

edit retag flag offensive close merge delete

Comments

Check the /etc/resolv.conf entries for nameserver. I'm running into a similar issue where my /etc/resolv.conf files contain an entry for a nameserver on my home network which don't work when I take my laptop to work and use the network there. Switching to 8.8.8.8 and restarting services fixed it.

medington-cb gravatar imagemedington-cb ( 2016-05-03 15:54:38 -0500 )edit