Nova Client - No module named openstack.common

asked 2016-04-28 15:24:25 -0600

jturner gravatar image

I am currently getting this error when running nova list.

ERROR (ImportError): No module named openstack.common

Versions: Python 2.7.11

PIP Upgrade Output: Requirement already up-to-date: rackspace-novaclient in /usr/local/lib/python2.7/site-packages Requirement already up-to-date: python-novaclient in /usr/local/lib/python2.7/site-packages (from rackspace-novaclient) Requirement already up-to-date: rackspace-auth-openstack in /usr/local/lib/python2.7/site-packages (from rackspace-novaclient) Requirement already up-to-date: os-diskconfig-python-novaclient-ext in /usr/local/lib/python2.7/site-packages (from rackspace-novaclient) Requirement already up-to-date: rax-scheduled-images-python-novaclient-ext in /usr/local/lib/python2.7/site-packages (from rackspace-novaclient) Requirement already up-to-date: os-networksv2-python-novaclient-ext in /usr/local/lib/python2.7/site-packages (from rackspace-novaclient) Requirement already up-to-date: os-virtual-interfacesv2-python-novaclient-ext in /usr/local/lib/python2.7/site-packages (from rackspace-novaclient) Requirement already up-to-date: rax-default-network-flags-python-novaclient-ext in /usr/local/lib/python2.7/site-packages (from rackspace-novaclient) Requirement already up-to-date: ip-associations-python-novaclient-ext in /usr/local/lib/python2.7/site-packages (from rackspace-novaclient) Requirement already up-to-date: oslo.i18n>=2.1.0 in /usr/local/lib/python2.7/site-packages (from python-novaclient->rackspace-novaclient) Requirement already up-to-date: oslo.serialization>=1.10.0 in /usr/local/lib/python2.7/site-packages (from python-novaclient->rackspace-novaclient) Requirement already up-to-date: requests!=2.9.0,>=2.8.1 in /usr/local/lib/python2.7/site-packages (from python-novaclient->rackspace-novaclient) Requirement already up-to-date: oslo.utils>=3.5.0 in /usr/local/lib/python2.7/site-packages (from python-novaclient->rackspace-novaclient) Requirement already up-to-date: iso8601>=0.1.9 in /usr/local/lib/python2.7/site-packages (from python-novaclient->rackspace-novaclient) Requirement already up-to-date: keystoneauth1>=2.1.0 in /usr/local/lib/python2.7/site-packages (from python-novaclient->rackspace-novaclient) Requirement already up-to-date: pbr>=1.6 in /Library/Python/2.7/site-packages (from python-novaclient->rackspace-novaclient) Requirement already up-to-date: six>=1.9.0 in /usr/local/lib/python2.7/site-packages (from python-novaclient->rackspace-novaclient) Requirement already up-to-date: PrettyTable<0.8,>=0.7 in /usr/local/lib/python2.7/site-packages (from python-novaclient->rackspace-novaclient) Requirement already up-to-date: simplejson>=2.2.0 in /usr/local/lib/python2.7/site-packages (from python-novaclient->rackspace-novaclient) Requirement already up-to-date: Babel!=2.3.0,!=2.3.1,!=2.3.2,!=2.3.3,>=1.3 in /usr/local/lib/python2.7/site-packages (from python-novaclient->rackspace-novaclient) Requirement already up-to-date: msgpack-python>=0.4.0 in /usr/local/lib/python2.7/site-packages (from oslo.serialization>=1.10.0->python-novaclient->rackspace-novaclient) Requirement already up-to-date: pytz>=2013.6 in /usr/local/lib/python2.7/site-packages (from oslo.serialization>=1.10.0->python-novaclient->rackspace-novaclient) Requirement already up-to-date: funcsigs>=0.4 in /usr/local/lib/python2.7/site-packages (from oslo.utils>=3.5.0->python-novaclient->rackspace-novaclient) Requirement already up-to-date: debtcollector>=1.2.0 in /usr/local/lib/python2.7/site-packages (from oslo.utils>=3.5.0->python-novaclient->rackspace-novaclient) Requirement already up-to-date: netifaces>=0.10.4 in /usr/local/lib/python2.7/site-packages (from oslo.utils>=3.5.0->python-novaclient->rackspace-novaclient) Requirement already up-to-date: netaddr!=0.7.16,>=0.7.12 in /usr/local/lib/python2.7/site-packages (from oslo.utils>=3.5.0->python-novaclient->rackspace-novaclient) Requirement already up-to-date: monotonic>=0.6 in /usr/local/lib/python2.7/site-packages (from oslo.utils>=3.5.0->python-novaclient->rackspace-novaclient) Requirement already up-to-date ... (more)

edit retag flag offensive close merge delete