Ask Your Question
0

Keystone authentication: Failed to contact the endpoint.

asked 2016-04-26 03:15:31 -0500

Badis BA gravatar image

updated 2016-07-05 10:17:52 -0500

rbowen gravatar image

Hi guys,

I'm trying to install Murano the applications catalog in RDO OpenStack by following this guide :

http://egonzalez.org/murano-in-rdo-op...

When i try to create the murano user in the Murano Node by using this command:

openstack user create –os-username admin –os-auth-url http://172.19.11.116:35357/v3 –os-project-name admin –os-identity-api-version 3 –password ***** murano

I get this authentication error:

Failed to contact the endpoint at http://Controller-Node:35357/v3 for discovery. Fallback to using that endpoint as the base url.
Unable to establish connection to http://Controller-Node:35357/v3/users

So what can i do to make the openstack endpoint reachable for the murano node ?

Regards,

edit retag flag offensive close merge delete

Comments

Hi Badis, are you using keystone v3 or v2.0? If you source your admin_keystonerc file and issue openstack user list, do you get a response?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-05-24 13:43:43 -0500 )edit

Hi eduardo, my keystone API version is v3 and yes when i issue openstack user list i get a response !

Badis BA gravatar imageBadis BA ( 2016-05-25 05:29:36 -0500 )edit

When you create the endpoint sourcing the file as the last step you made, you get an error or success. Can you also paste both commands with source and without source with --debug added in the command? We can see what is wrong in the request, also, this is not an issue with murano is at keystone?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-05-25 06:20:45 -0500 )edit

Ping, Badis, any feedback on Eduardo's question?

rbowen gravatar imagerbowen ( 2016-07-05 10:19:01 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2016-08-29 09:37:31 -0500

updated 2016-08-29 09:40:49 -0500

Note that sometimes you have IP address and sometimes you have Hostnames specified.
The initial AUTH URL uses the IP address:

http://172.19.11.116:35357/v3 Which seems to succeed. It then should get the identity endpoint out of the service catalog, and that seems to be using the hostname:

http://Controller-Node:35357/v3

Apache or HA Proxy is not responding to this, probably as it needs to be in the vhost section of the Keystone Config file. Either change the endpoint to use the IP address, or, even better, make Apache respond to requests for the Hostname.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-04-26 03:15:31 -0500

Seen: 3,150 times

Last updated: Aug 29 '16