Ask Your Question
2

Openstack Mitaka: can not access dashboard

asked 2016-04-21 01:29:27 -0500

Rock gravatar image

Hi all, I installed openstack in a two-node environment on ubuntu 14.04 following the guide: http://docs.openstack.org/mitaka/install-guide-ubuntu/ (http://docs.openstack.org/mitaka/inst...)

Everything was good prior to installing dashboard. I could create provider network and launch a VM.

After installing dashboard I tried to access it: http://controller/horizon I only got "Internal Server Error" on the browser.

Here are some logs in /var/log/apache2/error.log:

[Thu Apr 21 14:04:06.877057 2016] [:info] [pid 19552:tid 140395806283520] mod_wsgi (pid=19552): Create interpreter 'controller|/horizon'. [Thu Apr 21 14:04:06.881281 2016] [core:trace1] [pid 19566:tid 140395728054016] util_script.c(601): [client 10.0.0.11:39397] Status line from script 'django.wsgi': 200 Continue [Thu Apr 21 14:04:06.881491 2016] [:info] [pid 19552:tid 140395806283520] [remote 10.0.0.11:27514] mod_wsgi (pid=19552, process='horizon', application='controller|/horizon'): Loading WSGI script '/usr/share/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi'. [Thu Apr 21 06:09:10.383992 2016] [:info] [pid 19552:tid 140395856639744] mod_wsgi (pid=19552): Daemon process deadlock timer expired, stopping process 'horizon'. [Thu Apr 21 06:09:10.384175 2016] [:info] [pid 19552:tid 140395945576320] mod_wsgi (pid=19552): Shutdown requested 'horizon'. [Thu Apr 21 06:09:15.384571 2016] [:info] [pid 19552:tid 140395584993024] mod_wsgi (pid=19552): Aborting process 'horizon'.

Looks like apache can't load "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi". I'm new for openstack and python. Would you please give me some hints on this issue?

Many thanks,

Rock

edit retag flag offensive close merge delete

Comments

Solved it: add following to /etc/apache2/conf-available/openstack-dashboard.conf WSGIProcessGroup horizon WSGIApplicationGroup %{GLOBAL} >>>>> add this line. and after that execute this on the given path: /usr/share/openstack-dashboard$ sudo python manage.py compress This should do.

Sanjay_1987 gravatar imageSanjay_1987 ( 2016-06-01 03:50:15 -0500 )edit

6 answers

Sort by ยป oldest newest most voted
1

answered 2016-05-31 16:41:12 -0500

chappavarapu gravatar image

updated 2016-05-31 16:49:34 -0500

Added the line WSGIApplicationGroup %{GLOBAL} to start of the file /etc/apache2/conf-available/openstack-dashboard.conf.

root@controller:~# cat /etc/apache2/conf-available/openstack-dashboard.conf WSGIApplicationGroup %{GLOBAL} WSGIScriptAlias /horizon /usr/share/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi WSGIDaemonProcess horizon user=horizon group=horizon processes=3 threads=10 WSGIProcessGroup horizon Alias /static /usr/share/openstack-dashboard/openstack_dashboard/static/ Alias /horizon/static /usr/share/openstack-dashboard/openstack_dashboard/static/ <directory usr="" share="" openstack-dashboard="" openstack_dashboard="" wsgi=""> Order allow,deny Allow from all </directory>

it worked.

edit flag offensive delete link more
0

answered 2016-05-18 23:01:34 -0500

todotani gravatar image

Try asscess to :
http://controller/dashboard

I can access dashbord with the above URL.

edit flag offensive delete link more
0

answered 2016-05-27 01:29:55 -0500

Sanjay_1987 gravatar image

updated 2016-05-27 01:31:29 -0500

I am facing the same issue with Mitaka release. Some snippet from my error.log from apache says:

[Fri May 27 11:41:13.655871 2016] [:info] [pid 5335:tid 139981529089792] mod_wsgi (pid=5335): Daemon process deadlock timer expired, stopping process 'horizon'. [Fri May 27 11:41:13.655968 2016] [:info] [pid 5335:tid 139981618030464] mod_wsgi (pid=5335): Shutdown requested 'horizon'. [Fri May 27 11:41:18.656158 2016] [:info] [pid 5335:tid 139981259777792] mod_wsgi (pid=5335): Aborting process 'horizon'. [Fri May 27 07:41:18.660286 2016] [core:error] [pid 5348:tid 139981439891200] [client 172.19.57.35:53643] End of script output before headers: django.wsgi [Fri May 27 07:41:18.660325 2016] [core:error] [pid 5347:tid 139981414713088] [client 127.0.0.1:34526] End of script output before headers: django.wsgi [Fri May 27 07:41:18.817586 2016] [:info] [pid 5331:tid 139981618030464] mod_wsgi (pid=5335): Process 'horizon' has died, restarting.

Anyone of you have solved it? Please suggest what am I missing? or there is some bug opened against this?

edit flag offensive delete link more

Comments

Solved it: add following to /etc/apache2/conf-available/openstack-dashboard.conf WSGIProcessGroup horizon WSGIApplicationGroup %{GLOBAL} >>>>> add this line.

and after that execute this on the given path:

/usr/share/openstack-dashboard$ sudo python manage.py compress

This should do.

Sanjay_1987 gravatar imageSanjay_1987 ( 2016-06-01 03:49:47 -0500 )edit
0

answered 2016-05-13 01:03:50 -0500

I'm facing the same issue after following installation for Ubuntu guide on Ubuntu 14.04.4. Bump!

Cannot load horizon dashboard.

edit flag offensive delete link more
0

answered 2016-05-05 10:58:19 -0500

I have the same problem :(. Bump! Guide here - using ubuntu 14.04:

http://docs.openstack.org/mitaka/install-guide-ubuntu/ (http://docs.openstack.org/mitaka/inst...) http://docs.openstack.org/mitaka/install-guide-ubuntu/horizon-install.html (http://docs.openstack.org/mitaka/inst...)

edit flag offensive delete link more

Comments

Solved it: add following to /etc/apache2/conf-available/openstack-dashboard.conf WSGIProcessGroup horizon WSGIApplicationGroup %{GLOBAL} >>>>> add this line. and after that execute this on the given path: /usr/share/openstack-dashboard$ sudo python manage.py compress This should do.

Sanjay_1987 gravatar imageSanjay_1987 ( 2016-06-01 03:50:11 -0500 )edit
0

answered 2016-05-17 15:09:05 -0500

ltore1234 gravatar image

updated 2016-05-17 15:09:55 -0500

same problem still waiting for the fix

edit flag offensive delete link more

Comments

Solved it: add following to /etc/apache2/conf-available/openstack-dashboard.conf WSGIProcessGroup horizon WSGIApplicationGroup %{GLOBAL} >>>>> add this line. and after that execute this on the given path: /usr/share/openstack-dashboard$ sudo python manage.py compress This should do.

Sanjay_1987 gravatar imageSanjay_1987 ( 2016-06-01 03:50:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2016-04-21 01:20:24 -0500

Seen: 5,415 times

Last updated: May 31 '16