Ask Your Question
0

Is it possible Open stack Havana (single node) setup, with single NIC card?

asked 2013-12-19 05:42:48 -0500

Mithun gravatar image

updated 2013-12-19 07:47:46 -0500

dheeru gravatar image

Hi All, I am using centos 6.4 (virtual machine installed on ESX server) to install open stack (devstack),with single node setup(All in one).

Centos on which open stack is installed have only one NIC card. (eht0).
 1. I install neutron service to this setup, 
 2.created public and private network , and routed them together following instruction given in user guide.
 3.added security rules to pas tcp/icmp traffic to the instance, and added keypair to ssh it from outer world.
 4. assigned private and public (floating ip) to the open stack instance (cirros).

what i found is, i am unable to ping the instance (with both private and floating ip) from centos on which open stack is installed, neither i can ssh to it as it ends with error message 'no route to the host'

My question is i sit because of single nic card (eth0) present on my centos causing me this issue..?
Is there any workaround for this problem..?

Any feedback will be very helpful.
Thanks..
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-12-19 07:03:08 -0500

dheeru gravatar image

I'm not sure about the dev-stack. I have done installation on Single NIC and made it work. I have just written(half complete) article on "Strategy for OpenStack Installation". I'm yet to put the complete details of configuration etc. Hopefully it will complete in another to days. I'm confident that dev-stack will not be something different. Since I have not tried on dev-stack, i'm not able to comment. You can visit this page see this half written article.

http://www.virtual2privatecloud.com/

edit flag offensive delete link more

Comments

@dheeru, thanks for the replay, by checking above link I see it will be very useful documentation for all who are new to open stack and wants to make their things run.Waiting for it completion. In mean time plz let me know if any other links can be followed to make this things run. Thanks

Mithun gravatar imageMithun ( 2013-12-19 22:25:30 -0500 )edit
1

Is it because network namespace issue..? As i am using centos 6.4 + devstack setup.And found that it does not support network namespace required for smooth working of open stack neutron service.

Mithun gravatar imageMithun ( 2013-12-19 23:39:35 -0500 )edit

Yes. It does require namespace. Did you check whether your kernel supports it ? Also did you install dkms package on your box ?

dheeru gravatar imagedheeru ( 2013-12-19 23:55:49 -0500 )edit

following are the links i am following to add network namespace and dkms.Then will lead to devstack installation. http://spredzy.wordpress.com/2013/11/22/enable-network-namespaces-in-centos-6-4/ http://saadbinakhlaq.wordpress.com/2012/11/07/installing-guest-additions-and-dkms-on-centos/ pl let me knw if any other precise way to do this.

Mithun gravatar imageMithun ( 2013-12-20 03:49:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2013-12-19 05:42:48 -0500

Seen: 907 times

Last updated: Dec 19 '13