magnum bay create timeout - You are not authorized to use global_index [closed]

asked 2016-04-18 09:13:22 -0500

Maik gravatar image

updated 2016-04-18 09:15:39 -0500

I run "magnum bay-create --name swarmbay --baymodel swarmbaymodel --node-count 1" as user (not admin) and get a timeout. I see only a warning in /var/lib/magnum/magnum-conductor.log

use global_index.\n", "type": "Forbidden"}, "title": "Forbidden"}
 log_http_response /usr/local/lib/python2.7/dist-packages/heatclient/common/http.py:155
15824: WARNING magnum.service.periodic [req-4cbf1448-a4f5-46f0-8eb5-053fa3ee045a - - - - -] Ignore error [ERROR: You are not authorized to use global_index.] when syncing up bay status.
15824: TRACE magnum.service.periodic Traceback (most recent call last):
15824: TRACE magnum.service.periodic   File "/opt/magnum/magnum/service/periodic.py", line 85, in sync_bay_status
15824: TRACE magnum.service.periodic     sid_to_stack_mapping = {s.id: s for s in stacks}
15824: TRACE magnum.service.periodic   File "/opt/magnum/magnum/service/periodic.py", line 85, in <dictcomp>
15824: TRACE magnum.service.periodic     sid_to_stack_mapping = {s.id: s for s in stacks}
15824: TRACE magnum.service.periodic   File "/usr/local/lib/python2.7/dist-packages/heatclient/v1/stacks.py", line 127, in paginate
15824: TRACE magnum.service.periodic     stacks = self._list(url, 'stacks')
15824: TRACE magnum.service.periodic   File "/usr/local/lib/python2.7/dist-packages/heatclient/openstack/common/apiclient/base.py", line 135, in _list
15824: TRACE magnum.service.periodic     body = self.client.get(url).json()
15824: TRACE magnum.service.periodic   File "/usr/local/lib/python2.7/dist-packages/heatclient/common/http.py", line 291, in get
15824: TRACE magnum.service.periodic     return self.client_request("GET", url, **kwargs)
15824: TRACE magnum.service.periodic   File "/usr/local/lib/python2.7/dist-packages/heatclient/common/http.py", line 284, in client_request
15824: TRACE magnum.service.periodic     resp, body = self.json_request(method, url, **kwargs)
15824: TRACE magnum.service.periodic   File "/usr/local/lib/python2.7/dist-packages/heatclient/common/http.py", line 273, in json_request
15824: TRACE magnum.service.periodic     resp = self._http_request(url, method, **kwargs)
15824: TRACE magnum.service.periodic   File "/usr/local/lib/python2.7/dist-packages/heatclient/common/http.py", line 228, in _http_request
15824: TRACE magnum.service.periodic     raise exc.from_response(resp)
15824: TRACE magnum.service.periodic HTTPForbidden: ERROR: You are not authorized to use global_index.
15824: TRACE magnum.service.periodic

Version

magnum-api --version: 2.0.1.dev1

magnum-conductor --version: 2.0.1.dev1

magnum --version: 2.0.1

trust

domain: magnum

domain_admin: magnum_admin <role> admin

Baymodel

+---------------------+--------------------------------------+
| Property            | Value                                |
+---------------------+--------------------------------------+
| http_proxy          | None                                 |
| updated_at          | None                                 |
| master_flavor_id    | m1.medium                            |
| uuid                | 418fd0b3-9893-498a-9ec1-04ab41a69e1e |
| no_proxy            | None                                 |
| https_proxy         | None                                 |
| tls_disabled        | True                                 |
| keypair_id          | testkey                              |
| public              | False                                |
| labels              | {}                                   |
| docker_volume_size  | 5                                    |
| server_type         | vm                                   |
| external_network_id | public                               |
| cluster_distro      | fedora-atomic                        |
| image_id            | fedora-23-atomic-7                   |
| volume_driver       | None                                 |
| registry_enabled    | False                                |
| apiserver_port      | None                                 |
| name                | swarmbaymodel                        |
| created_at          | 2016-04-18T12:53:08+00:00            |
| network_driver      | docker                               |
| fixed_network       | None                                 |
| coe                 | swarm                                |
| flavor_id           | m1.small                             |
| dns_nameserver      | 134.76.10.46                         |
+---------------------+--------------------------------------+

/etc/heat/policy.json

"stacks:generate_template": "rule:deny_stack_user",
"stacks:global_index": "rule:admin",
"stacks:index": "rule:deny_stack_user",

How can i avoid "You are not authorized to use global_index." ?

How can i avoid the timeout?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Maik
close date 2016-04-19 05:50:48.966944

Comments

Actually, there are two issues: the not authorized error and the timeout issue. For the authorization error, could you paste your magnum config file (/etc/magnum/magnum.conf) with credentials removed.

hongbin034 gravatar imagehongbin034 ( 2016-04-18 09:56:53 -0500 )edit

For the timeout issue, could you type these two commands for me and paste me the output: $ heat stack-list -n $ heat resource-list For details, here is the trouble-shooting guide: http://docs.openstack.org/developer/m...

hongbin034 gravatar imagehongbin034 ( 2016-04-18 09:58:22 -0500 )edit

Thank for help. But it works now. At the moment i do not exactly know why but i think it was a misconfiguration of policy.json because i have to controller nodes and one has no "stacks:global_index": "rule:admin"

Now i have a new problem but i will create a new thread for this.

Maik gravatar imageMaik ( 2016-04-19 05:49:01 -0500 )edit

Maik, i am also facing the same issue. In policy.json there is no entry for "stacks:global_index": "rule:admin". I have done all things through admin user. Also tried adding above entry and restarting magnum service but didnt work. My magnum bay creation is also stuck.Are both the issues related?

mostwanted gravatar imagemostwanted ( 2016-09-15 10:53:53 -0500 )edit

I am working on single node setup

mostwanted gravatar imagemostwanted ( 2016-09-15 10:54:31 -0500 )edit