l3 agent does not create qrouter namespace in ha

asked 2013-12-19 02:26:08 -0500

Marco Marino gravatar image

Hi, i'm using openstack havana with a dedicated network node (openvswitch + gre). I'm following this guide for ha -> http://docs.openstack.org/high-availability-guide/content/_adding_neutron_l3_agent_resource_to_pacemaker.html . On network1 it works well, qrouter and qdhcp namespaces are created. When i move services on network2 only qdhcp namespace is created. Why this happens? How can i debug this case? I'm using same kernel version and same configuration files (except for local_ip in the openvswitch plugin configuration file). Someone can help me? Thank you.

edit retag flag offensive close merge delete

Comments

Any progress on this?

igordcard gravatar imageigordcard ( 2014-03-13 13:04:46 -0500 )edit

Hi, I am stuck with same scenario. Dose any one have suggestion/solution for this issue.

rahulrajvn gravatar imagerahulrajvn ( 2014-07-21 13:06:10 -0500 )edit

Do you have a br-ex interface associated to an interface that allows connectivity between your internal network and external network? For example, your ovs-vsctl show on primary node should look the same as on the failover node.

schmaustech gravatar imageschmaustech ( 2015-01-25 06:51:42 -0500 )edit