How to overcome Dell Server unpredicable naming convention

asked 2016-04-15 01:13:45 -0500

gwyndiion gravatar image

updated 2016-04-15 01:16:44 -0500

During the installation via Fuel (Mirantis 7.0 Kilo) I am trying to force my Dell PowerEdge R630 to associate eth0 with the first physical port. There are a number of links to predicable naming, and how to turn this off. The most popular answer on this forum looks to point to https://ask.openstack.org/en/question/29166/helion-installation-query/ (https://ask.openstack.org/en/question...).

Using the command in Fuel CLI : cobbler profile report, I can see that the profile is setting the kernel options that include the biosdevname=0

Kernel Options                 : {'console': ['ttyS0,9600', 'tty0'], 'url': 'http://10.20.0.2:8000/api', 'mco_user': 'mcollective', 'biosdevname': '0', 'mco_pass': 'E1KjB7PZ', 'intel_pstate': 'disable'}

I did modify directly the /etc/udev/rules.d/70-persistent-net.rules, but obviously when I PXE boot this host for connectivity to Fuel, the contents get overwritten by the boot from Fuel Master Node.

    root@node-5:~# cat /etc/udev/rules.d/70-persistent-net.rules
    # Generated by fuel-agent during provisioning: BEGIN
    #SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="14:18:77:46:dc:3d", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
    ##SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="14:18:77:46:dc:3e", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"
    #SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="14:18:77:46:dc:3b", ATTR{type}=="1", KERNEL=="eth*", NAME="eth2" <<<< lowest numbered MAC should be eth0 (with the other interfaces incrementing after this one)
    #SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="14:18:77:46:dc:3c", ATTR{type}=="1", KERNEL=="eth*", NAME="eth3"
    # Generated by fuel-agent during provisioning: END

There are a number of threads of reference to the use of biosdevname=0 as being the solution, but this does not overcome the seemingly randomness delivered by Dell ! So, I think that it would be preferable to use native naming convention as a workaround for the Dell naming pattern.

HOWEVER, there is discussion that without ethx naming convention this may break other components in the Fuel deployment, and so set the biosdevname=0. This is contradicted by the answer in https://ask.openstack.org/en/question/88686/nic-name-enonumber-on-centos/ (https://ask.openstack.org/en/question...) ("By now you probably already know that yes, you can (actually, you HAVE TO) use the native interface names you system offers you, to configure your software... )

So I am confused?!

Two questions:

  1. Does anyone have a solution with Dell PowerEdge R630 where the MAC addresses are not randomized (but in order) (and what is the environment that solves this ?)

  2. Do we need ethx for Fuel deployments, or can we use the native naming conventions (biosdevname=1 ?) ??

edit retag flag offensive close merge delete

Comments

I updated the kernel_options in fuel, and set the biosdevname=1, did a cobbler sync, and PXE boot again. still getting the ethx names, and the /etc/udev/rules.d/70-persistent-net.rules file show the ethx interfaces (but not yet showing the generated by fuel, as above) on initial boot.

gwyndiion gravatar imagegwyndiion ( 2016-04-15 02:12:36 -0500 )edit