Ask Your Question
0

keystone works in apache [closed]

asked 2013-12-18 22:21:49 -0500

nethawk gravatar image

My keystone works normal,but when I put it into apache2,it can not work. when I check the error log,I found this errors:

ConfigFilesNotFoundError: Failed to read some config files: /etc/keystone/keystone.conf

So ,how can I deal with it?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by nethawk
close date 2013-12-20 03:32:37.105350

3 answers

Sort by ยป oldest newest most voted
1

answered 2013-12-20 03:32:14 -0500

nethawk gravatar image

This problem has been resolved.The reanson is the owner of directory SSL in /etc/keystone,after I change it,it is all right. Thanks very much.

edit flag offensive delete link more
1

answered 2013-12-19 03:38:56 -0500

dheeru gravatar image

updated 2013-12-20 05:17:06 -0500

This error means that it is either path of configuration file is not correct or permission issue. I suspect it is path issue only. Check the permission and owner of these files. They should be readable by the HTTPD process.

Check keystone.ini file, you can sanitize and post it on http://paste.openstack.org (edit your question adding a link to it)

Also in very remote case can you check the following bug https://bugs.launchpad.net/openstack-common/+bug/1012671

Check the command line options of how apache is launched and how the keystone.conf is specified in the command line. Check whether it is specified as --config-file=~/etc/keystone.conf where ~ may not work. You need to specify the full path. Either you can check the start-up script or do ps -aef | grep apache on your box.

Summary

Issue has been resolved after changing the permission of ssl directory in keystone.

edit flag offensive delete link more

Comments

[root@ommp-openstack httpd]# ps -ef|grep httpd root 15336 1 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15338 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15339 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15340 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15341 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd

nethawk gravatar imagenethawk ( 2013-12-19 21:07:32 -0500 )edit
-1

answered 2013-12-19 19:28:35 -0500

nethawk gravatar image

@dheeru Thanks for your help. But now I recieve 500 error.

Now I show you my files and some command results. And I don't use keystone-paste.ini.

[root@ommp-openstack httpd]# ps -ef|grep httpd root 15336 1 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15338 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15339 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15340 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15341 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15342 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15343 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15344 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15345 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15346 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15347 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15348 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15349 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15350 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd apache 15351 15336 0 09:02 ? 00:00:00 /usr/sbin/httpd

[root@ommp-openstack keystone]# ll total 40 -rw-r----- 1 root keystone 1539 Aug 9 01:41 default_catalog.templates -rwxrwxrwx 1 apache apache 9999 Dec 16 10:46 keystone.conf -rw-r----- 1 root root 10016 Oct 23 16:49 keystone.conf.bak.bak -rw-r----- 1 apache apache 1063 Nov 27 10:18 logging.conf -rw-r----- 1 keystone keystone 3983 Aug 9 01:41 policy.json drwxr-xr-x. 4 apache apache 4096 Sep 23 17:32 ssl

[root@ommp-openstack keystone]# ll total 200 -rw-r--r-- 1 root root 164 Dec 19 17:15 apache2-admin-access.log -rw-r--r-- 1 root root 179 Dec 19 17:15 apache2-admin-error.log -rw-r--r-- 1 root root 1571 Dec 20 09:02 apache2-main-access.log -rw-r--r-- 1 root root 27162 Dec 20 09:02 apache2-main-error.log -rw-r--r-- 1 apache apache 152718 Dec 19 17:33 keystone.log

/etc/httpd/conf.d/keystone.conf: NameVirtualHost *:5000 Listen 5000 <virtualhost *:5000=""> ServerName keystone-main WSGIScriptAlias / /usr/keystone/main #WSGIDaemonProcess keystone user=root group=root processes=10 threads=10 WSGIDaemonProcess keystone WSGIProcessGroup keystone</virtualhost>

SSL Config

#SSLEngine on #SSLCertificateFile /etc/ssl/certs/server.crt #SSLCertificateKeyFile /etc/ssl/private/server.key

ErrorLog /var/log/keystone/apache2-main-error.log LogLevel debug CustomLog /var/log/keystone/apache2-main-access.log common

NameVirtualHost *:35357 Listen 35357 <virtualhost *:35357=""> ServerName keystone-admin WSGIScriptAlias / /usr/keystone/admin #WSGIDaemonProcess root user=root group=root processes=10 threads=10 #WSGIProcessGroup root</virtualhost>

SSL Config

#SSLEngine on #SSLCertificateFile /etc/ssl/certs/server.crt #SSLCertificateKeyFile /etc/ssl/private/server.key

ErrorLog /var/log/keystone/apache2-admin-error.log LogLevel debug CustomLog /var/log/keystone/apache2-admin-access.log common

/usr/keystone/keystone.py:

#!/usr/bin/python import sys import os import greenlet import eventlet import socket import signal

possible_topdir = os.path.normpath(os.path.join(os.path.abspath(__file__), os ... (more)

edit flag offensive delete link more

Comments

By the way,In apache,command line can execute normally,such as I execute "keystone user-list",I can get the right result.But I sent API from remote or use dashboard,it occurs 500.

nethawk gravatar imagenethawk ( 2013-12-19 20:09:51 -0500 )edit

Honestly I saw too much information and did not get correct problem. Here is what I have understood. If your run the command you get the right output. If you make API request, you have problem. Is that correct. Here is my suggestion. Let us close this request. Open a new request. In that please mention how you are making API request. I would like to see the complete API request.

dheeru gravatar imagedheeru ( 2013-12-20 00:56:55 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-18 22:21:49 -0500

Seen: 293 times

Last updated: Dec 20 '13