Ask Your Question
0

Can ping to dhcp server from controller node but not from compute nodes. [closed]

asked 2016-04-12 09:54:30 -0500

syko gravatar image

updated 2016-04-12 10:12:45 -0500

Hi,

Each node has two NIC: 1Gb Eth (eth0), Infiniband (ib0). By following the installation tutorials (http://docs.openstack.org/liberty/install-guide-ubuntu (http://docs.openstack.org/liberty/ins...)), I set up a controller node and two compute nodes.

I can run two nova instances with provider network with eth0 interface. There is no problem.

But I have some problems in deploying provider network with ib0 interface. I found two weird behaviors related with it.

  1. No node can ping to VMs attached to ib0 interface.
  2. Controlloer node can ping to the dhcp agent server running on the controller node, but the other compute nodes cannot ping to it.

Thanks for any information.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by syko
close date 2016-04-22 22:04:49.488926

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-04-22 22:04:32 -0500

syko gravatar image

This issue was related with DHCP namespace resolution, if your have a similar behaviors (you cannot ping to neither to DHCP server or nova instance) you should check the namespace of it.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-04-12 09:54:30 -0500

Seen: 44 times

Last updated: Apr 22 '16