Ask Your Question
0

How do I get the host to listen on port 22

asked 2016-04-06 17:42:34 -0500

scorcoran gravatar image

updated 2016-04-07 01:19:27 -0500

Bipin gravatar image

When following the Quickstart instructions, upon executing $packstack --allinone I get this error:

ERROR : Failed handling answer file: Given host does not listen on port 22: 192.168.1.10

Quickstart has this among its prerequisites:

"If you plan on having external network access to the server and instances, this is a good moment to properly configure your network settings. A static IP address to your network card, and disabling NetworkManager are good ideas."

I didn't plan to have external network access so I preceded with the installation command, but it seems I must have the host listen on port 22.

I read this answer [1] but it didn't help. Obviously I know next to nothing about networking. I've researched quite a bit and tried a couple things with no success. I'm assuming this is a very simple task for someone more knowledgeable. Any help is appreciated.

thanks, Stuart

[1] https://ask.openstack.org/en/question/11652/host-does-not-listen-on-port-22/

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-04-07 03:49:17 -0500

dbaxps gravatar image

updated 2016-04-07 03:52:47 -0500

Hard to complete :-

    firewall-cmd --add-port=22/tcp
    firewall-cmd --add-port=22/tcp --permanent
    systemctl start sshd
    systemctl enable sshd
edit flag offensive delete link more

Comments

Thank you. That worked. Unfortunately the install failed later on (during HA installation). But that's another problem to research...

scorcoran gravatar imagescorcoran ( 2016-04-08 19:20:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-04-06 17:42:34 -0500

Seen: 949 times

Last updated: Apr 07 '16