Ask Your Question
0

Cannot connect to VM, receiving Alert!?

asked 2013-05-08 10:40:03 -0500

henrik16 gravatar image

Hi, I'm trying to connect to my VM one more time.. I followed this steps, I've done all on controller(cloud) node except the last step...(done in network node) so when I try to run ip netns exec <ID> ssh <ip_address> I recieve this alert:

root@network:~# ip netns exec qdhcp-61a3cfe5-fd33-4987-8937-ee96dc0dbe27 ssh 10.5.5.2
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    @    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that a host key has just been changed.
    The fingerprint for the ECDSA key sent by the remote host is
    51:56:94:ce:a4:c7:32:32:69:db:01:75:4f:cc:a0:e4.
    Please contact your system administrator.
    Add correct host key in /root/.ssh/known_hosts to get rid of this message.
    Offending ECDSA key in /root/.ssh/known_hosts:1
      remove with: ssh-keygen -f "/root/.ssh/known_hosts" -R 10.5.5.2
    ECDSA host key for 10.5.5.2 has changed and you have requested strict checking.
    Host key verification failed.

Why am I recieving this ?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2013-05-08 18:58:31 -0500

smaffulli gravatar image

The error from ssh client tells you what's wrong:

Add correct host key in /root/.ssh/known_hosts to get rid of this message.

and the same error message tells you how to solve it:

  remove with: ssh-keygen -f "/root/.ssh/known_hosts" -R 10.5.5.2

This should do it.

edit flag offensive delete link more

Comments

Thanksmaffulli, the problem is that I'm portuguse so sometimes I have this kind of problems when trying to understand some error messages. Now the error don't come up but when I run the ip netns exec I receive permision denied (public key)

henrik16 gravatar imagehenrik16 ( 2013-05-09 03:38:36 -0500 )edit

I have done all the steps in network node and now I don't recieve permission denied but I recieve : root@network:~# ip netns exec qdhcp-61a3cfe5-fd33-4987-8937-ee96dc0dbe27 ssh 10.5.5.4 Please login as the user "ubuntu" rather than the user "root".

Connection to 10.5.5.4 closed.

henrik16 gravatar imagehenrik16 ( 2013-05-09 03:49:47 -0500 )edit

Solved: changed ip netns exec qdhcp-61a3cfe5-fd33-4987-8937-ee96dc0dbe27 ssh 10.5.5.4 to ip netns exec qdhcp-61a3cfe5-fd33-4987-8937-ee96dc0dbe27 ssh ubuntu@10.5.5.4

henrik16 gravatar imagehenrik16 ( 2013-05-09 03:54:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-08 10:40:03 -0500

Seen: 476 times

Last updated: May 08 '13