Instance IP address not reachable

asked 2016-04-05 09:00:26 -0600

Nogginboink gravatar image

I have installed OpenStack Liberty with 1 controller and 1 compute node. The two nodes have 2 NICs: the management interface is on 10.0.0.x and the second NIC is unnumbered per the environment setup instructions.

Because of the limited IP address ranges I have available to me, I want the instance public IP's to be on the 10.0.0.x subnet, which is the same subnet as the management network.

When everything was built, I used the Horizon interface to create and launch an instance using the cirros image that is installed as part of the deployment guide. Horizon tells me that my instance is up and running and has an IP address of, which is in the DHCP range I created.

However, I can't ping this instance from either the management node nor the compute node, nor from another host on the 10.0.0.x subnet. Additionally, the Console tab in Horizon shows "Server disconnected (code: 1006)."

If I edit /etc/neutron/plugins/ml2/linuxbridge_agent.ini to use the management NIC for the public physical_interface_mapping on the compute and controller nodes, and then reboot both nodes and reboot the instance, the same thing happens.

My virtual router is on IP address, and I can ping that virtual interface. I have my instance ( connected to the "Public" network, which is also connected to the router ( per the Network Topology view.

How do I troubleshoot this?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2016-04-05 09:22:53 -0600

hkominos gravatar image

1)ignore the horizon and check the cirros if you truly got that ip. Horizon does not guarantee that that ip is correct. 2)if you use ip netns exec qdhcp* ping can you ping that machine?

edit flag offensive delete link more


How do I check if the Cirros instance actually got that IP? The console won't connect, and without the instance's IP address I can't ssh into it.

Nogginboink gravatar imageNogginboink ( 2016-04-05 12:43:33 -0600 )edit

When you boot cirros you have 2 ways. 1 click on the name of the vm and in the next panel go the log tab -view full log. and check that or click at console (wont work) ->click show to show only console->in the new tab change the host name with the horizon ip. ex.

hkominos gravatar imagehkominos ( 2016-04-06 04:07:17 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2016-04-05 09:00:26 -0600

Seen: 1,154 times

Last updated: Apr 05 '16