Ask Your Question
0

Access internet from instance

asked 2016-04-05 07:39:07 -0600

JeroenH gravatar image

updated 2016-04-07 01:05:19 -0600

Bipin gravatar image

On this moment i have my OpenStack environment running. I am testing connectivity from an instance. The instance i have chosen is a Ubuntu cloud instance. The problem is: I can's get apt to work from this instance. Ping to an url on the internet works. I can ssh to this instance.

On this moment, wget a file from the internet doesn't work either:

"Connecting to speedtest.dal01.softlayer.com (speedtest.dal01.softlayer.com)|74.86.116.210|:80... connected.
HTTP request sent, awaiting response..."

The HTTP-request is sent but it seems it can's return.

So i guess this is a problem with the secgroup. I opened port 80 and port 22 for this instance. In a nmap scan from another computer i get port 22 open, but port 80 closed. The iptables on the instance is empty. I also flushed it again.

nmap port scan of the instance :

PORT   STATE  SERVICE
22/tcp open   ssh
80/tcp closed http

does anyone have any idea? Thanks you!

edit retag flag offensive close merge delete

Comments

Maybe you have a wrong MTU size, are you using vxlan or gre tunnels? check what mtu size have your instance with ip a

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-04-05 08:35:19 -0600 )edit

Hi Eduaro, I am using GRE tunnels. The command "ip a" returns MTU 1500 on the instance on interface eth0.

JeroenH gravatar imageJeroenH ( 2016-04-05 09:30:50 -0600 )edit

GIve mtu to 1454 with:

sudo ip link set mtu 1454 eth0

If that solves your problem, change mtu size at dnsmask file at /etc/neutron/, if not, that will be another issue.

Regards

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-04-05 09:46:42 -0600 )edit

Thank you for your reply Eduaro,

Is there any difference in using MTU 1400 and MTU 1454 for eth0? (see answer below)

JeroenH gravatar imageJeroenH ( 2016-04-05 09:53:24 -0600 )edit

Theoretically there is a difference,a networking expert guy would say that. For a PoC, it just simply works! The difference is the frame bits reserved for encapsulation, probably there is a performance issue have the wrong mtu. If there is a networking expert, correct me please.

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2016-04-05 10:13:33 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-04-05 09:51:42 -0600

JeroenH gravatar image

Allright Eduaro,

Changing the MTU-size from 1500 to 1400 solved my problem. I used the following commands:

$ sudo ip link set mtu 1400 dev eth0 $ sudo ip link show dev eth0

Instantly it started working like a charm!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-04-05 07:39:07 -0600

Seen: 222 times

Last updated: Apr 07 '16