Ask Your Question
0

Is it possible to install and use Fuel only with 2 networks?

asked 2016-04-04 02:23:20 -0500

Porunov gravatar image

I have two networks
192.168.57.0 /24 is a private network
192.168.56.0 /24 is a public network (Internet is available through the gateway 192.168.56.10)

I have installed Fuel node and it works even it detects all nodes but default network do not work. I do not know how to configure it.
Verification shows:

Verification failed. Repo availability verification using public network failed on following nodes Controller1. Following repos are not available - http://archive.ubuntu.com/ubuntu/, http://mirror.fuel-infra.org/mos-repos/ubuntu/8.0/ (http://mirror.fuel-infra.org/mos-repo...) . Check your public network settings and availability of the repositories from public network. Please examine nailgun and astute logs for additional details.

I understand that public network doesn't configured properly. By default it 172.16.0.0/24 but if I change it to 192.168.56.0 /24 it shows:

Address space intersection between networks:
admin (PXE), public

I do not know how to avoid this error. Can somebody help me, please?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-04-04 05:40:34 -0500

hkominos gravatar image

I think you need to specify more information about your deployment. Anyway though. What the message says is that it cannot contact the update repositories. My guess is that you have not specified the dns server in fuelmenu.(and restart fuel master).
That was the problem for me at least

edit flag offensive delete link more

Comments

What is fuel menu? I have installed fuel 8. Before the installation I have choose DNS server, gateway server and a public network. After the Master node Installation I checked Internet availability. It works on the Master node. Then I started two Slave nodes.

Porunov gravatar imagePorunov ( 2016-04-04 05:53:31 -0500 )edit

Then I logged on Fuel UI, created new environment and added two nodes (Controller, Compute). Logically default network didn't work because there was incorrect public network 172.16.0.0/24.

Porunov gravatar imagePorunov ( 2016-04-04 05:54:07 -0500 )edit

Real public network is 192.168.56.0/24 but I can't choose it because it says: Address space intersection between networks: admin (PXE), public

Porunov gravatar imagePorunov ( 2016-04-04 05:54:15 -0500 )edit

type fuelmenu on fuel master and check the dns settings. There is a field with the dns value use the check button to see if the fuel master can get outside. (I have fuel 7,0). As for the networking part this is more complex . Can you please specify exactly your settings from Fuel UI

hkominos gravatar imagehkominos ( 2016-04-04 08:32:51 -0500 )edit

+Are running on virtualbox? It goes without saying that PXE (10.20.0x)is different from any other networks you might have

hkominos gravatar imagehkominos ( 2016-04-04 08:54:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-04-04 02:23:20 -0500

Seen: 573 times

Last updated: Apr 04 '16