Ask Your Question
0

openstack horizon : Internal server error.

asked 2016-04-01 11:07:01 -0500

Badis BA gravatar image

Hi everyone,

After following the OpenStack liberty Install guide, i'm now in the step of trying to access the dashboard for the first time but every time i try to access horizon this message shows up:

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Apache/2.4.7 (Ubuntu) Server at 172.19.11.116 Port 80


So anyone who could help ?

Best regards,

edit retag flag offensive close merge delete

Comments

can you paste last 5 lines of apache error log /var/log/apache2/error.log

Bipin gravatar imageBipin ( 2016-04-02 23:02:52 -0500 )edit

@Bipin,

The /var/log/apache2/error.log file is empty ! and now when i try to start the apache2 service i got this error :

(13)Permission denied: AH00072 : make_sock: could not bind to address [::] : 80 (13)Permission denied: AH00072 : make_sock: could not bind to address 0.0.0.0:80

Badis BA gravatar imageBadis BA ( 2016-04-04 02:38:20 -0500 )edit

ok @Bipin this are the last 5 lines:

[Mon Apr 04 09:05:53.405825 2016] [:error] [pid 3851:tid 140387473340160] [remote 127.0.0.1:42119] 'default_ipv4_subnet_pool_label': None, [Mon Apr 04 09:05:53.405834 2016] [:error] [pid 3851:tid 140387473340160] [remote 127.0.0.1:42119] ^ [Mon Apr 04 09

Badis BA gravatar imageBadis BA ( 2016-04-04 03:00:27 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
0

answered 2016-04-04 08:16:59 -0500

Badis BA gravatar image

I solved this problem by removing the apache2 service and reinstalling it again ! it's a very buggy solution but in the end it worked !!

edit flag offensive delete link more
0

answered 2016-11-19 10:46:38 -0500

The horizon error logs are available at /var/log/apache2/horizon_error.log. As a fix to this error, ensure the host IP onto which horizon is being served from is in the ALLOWED_HOSTS. More info, consult this bug file: https://bugs.launchpad.net/devstack/+bug/1643050 (https://bugs.launchpad.net/devstack/+...)

For the lazy ones.. :). Until a better solution comes up, for now this fix works:

  1. Head over to the file: /opt/stack/openstack/horizon/blob/master/openstack_dashboard/local/local_settings.py

  2. Edit the line #ALLOWED_HOSTS=['YOUR_HOST_IP',] to suit yours.

    E.g in mine, I have edited to this: ALLOWED_HOSTS=['192.168.10.99',]

    **192.168.10.99** --being the IP address of the host onto which
    horizon is installed on.
    
  3. Restart apache webserver with sudo service apache2 restart

  4. Then check if it all works on the browser: http://YOUR_HOST_IP/dashboard

Happy testing...

edit flag offensive delete link more
0

answered 2019-05-08 04:04:53 -0500

Make sure that you have added the following line

WSGIApplicationGroup %{GLOBAL}

In the file /etc/httpd/conf.d/openstack-dashboard.conf

and then restart the httpd service.

I hope this will resolve your problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-04-01 11:07:01 -0500

Seen: 6,815 times

Last updated: Mar 03 '18