Aborting wait for keystone to start

asked 2013-12-18 06:29:41 -0600

updated 2013-12-19 02:11:04 -0600

Hi,

I installed a fresh Openstack Havana and I make saome changes on keystone.conf to configure LDAP and SSL. Now, when I execute service openstack-keystone start prompt show me this message (after a long time):

# service openstack-keystone start
Starting keystone:                                         [  OK  ]

Aborting wait for keystone to start

I don't know what is the reason for this fail. However, If I execute keystone-all --debug the server starts, but I only can make requests via CURL, the keystone client can't communicate with the server.

Someone knows what is the problem? Any clue?

UPDATE:

Ok, I don't know how but I step forward a bit. Now, when I start openstack-keystone the keystone.log is wrote. But, if I execute keystone user-list it raises this message:

Authorization Failed: Unable to establish connection to https://128.142.153.64:35357/v3/tokens

And the log file is not updated with any information.

Regards.

edit retag flag offensive close merge delete

Comments

what do you see in /var/log/keystone/keystone.log ? Any debugs you see continously ?

dheeru gravatar imagedheeru ( 2013-12-18 07:38:19 -0600 )edit

keystone.log is not wrote when execute openstack-keystone. But if I execute keystone-all and I run a command like curl --insecure -H "X-Auth-Token:thetoken" https://localhost:35357/v3/users the keystone.conf is wroted

Marcos F. Lobo gravatar imageMarcos F. Lobo ( 2013-12-18 08:13:50 -0600 )edit

after aborting your keystone may not be running. Did it work without SSL support ?

dheeru gravatar imagedheeru ( 2013-12-19 08:02:46 -0600 )edit