Openstack APIs testing using REST Client - 403 Forbidden Response

asked 2016-03-30 01:12:29 -0500

ajithpathiyil gravatar image

updated 2016-03-30 04:33:25 -0500

Bipin gravatar image

Hi All,

I am testing the Openstack API's with a REST client (Firefox plugin), My authentication seems to be fine with the below POST, I also receive a response header with X-Subject-Token & I readily have X-Auth-Token from my

/etc/keystone/keystone.conf file.

My further API calls end-up in 403 Forbidden errors (Which means successful authentication but not privileged to perform the action), Where do I check if I have necessary privileges to perform the actions.

Note:- I am using X-Auth-Token value from /etc/keystone/keystone.conf in my headers (i.e. all my calls are with admin token)

Successful Keystone Authentication - API call

Method: POST
*Request Headers:
Content-type : application/json
*Request Body:
{
    "auth": {
        "identity": {
            "methods": [
                "password"
            ],
            "password": {
                "user": {
                    "name": "admin",
                    "password": "password",
                    "domain": {
                               "name":"Default"
                            }

                }
            }
        }
    }
}

Successful Keystone Authentication API call

edit retag flag offensive close merge delete

Comments

Can you provide an example of your successive API calls that fail? Thanks.

zetret12 gravatar imagezetret12 ( 2016-09-26 13:47:30 -0500 )edit