Ask Your Question
0

Error: Could not start Service[httpd]: Execution of '/usr/bin/systemctl start httpd' returned 1

asked 2016-03-29 18:31:17 -0500

heena gravatar image

Hi I am getting below error while installing openstack-packstack from answer file. I am unable to start httpd. Can anyone help me?

Applying 192.168.72.152_cinder.pp
192.168.72.152_keystone.pp:                       [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.72.152_keystone.pp
Error: Could not start Service[httpd]: Execution of '/usr/bin/systemctl start httpd' returned 1: Job for httpd.service failed because a timeout was exceeded. See "systemctl status httpd.service" and "journalctl -xe" for details.
You will find full trace in log /var/tmp/packstack/20160329-155117-MeMHLQ/manifests/192.168.72.152_keystone.pp.log
Please check log file /var/tmp/packstack/20160329-155117-MeMHLQ/openstack-setup.log for more information
Additional information:
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * Warning: NetworkManager is active on 192.168.72.152. OpenStack networking currently does not work on systems that have the Network Manager service enabled.
 * File /root/keystonerc_admin has been created on OpenStack client host 192.168.72.152. To use the command line tools you need to source the file.
 * NOTE : A certificate was generated to be used for ssl, You should change the ssl certificate configured in /etc/httpd/conf.d/ssl.conf on 192.168.72.152 to use a CA signed cert.
 * To access the OpenStack Dashboard browse to https://192.168.72.152/dashboard .
Please, find your login credentials stored in the keystonerc_admin in your home directory.
 * To use Nagios, browse to http://192.168.72.152/nagios username: nagiosadmin, password: ec59246a857f41d1
[root@controller ~]# systemctl status  httpd
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/httpd.service.d
           └─openstack-dashboard.conf
   Active: failed (Result: timeout) since Tue 2016-03-29 16:07:32 PDT; 8min ago
     Docs: man:httpd(8)
           man:apachectl(8)
  Process: 127772 ExecStartPre=/usr/bin/python /usr/share/openstack-dashboard/manage.py compress --force (code=exited, status=0/SUCCESS)
  Process: 127539 ExecStartPre=/usr/bin/python /usr/share/openstack-dashboard/manage.py collectstatic --noinput --clear (code=exited, status=0/SUCCESS)
 Main PID: 40566 (code=exited, status=0/SUCCESS)

Mar 29 16:07:00 controller python[127772]: ERROR:scss.ast:Function not found: twbs-font-path:1
Mar 29 16:07:32 controller python[127772]: Found 'compress' tags in:
Mar 29 16:07:32 controller python[127772]: /usr/share/openstack-dashboard/openstack_dashboard/templates/_stylesheets.html
Mar 29 16:07:32 controller python[127772]: /usr/share/openstack-dashboard/openstack_dashboard/templates/horizon/_conf.html
Mar 29 16:07:32 controller python[127772]: /usr/share/openstack-dashboard/openstack_dashboard/templates/horizon/_scripts.html
Mar 29 16:07:32 controller python[127772]: Compressing... done
Mar 29 16:07:32 controller python[127772]: Compressed 4 block(s) from 3 template(s).
Mar 29 16:07:32 controller systemd[1]: Failed to start The Apache HTTP Server.
Mar 29 16:07:32 controller systemd[1]: Unit httpd.service entered failed state.
Mar 29 16:07:32 controller systemd[1]: httpd.service failed.
edit retag flag offensive close merge delete

Comments

I had to un install and reinstall httpd and the it worked

heena gravatar imageheena ( 2016-05-25 07:09:45 -0500 )edit

install and reinstall will start httpd and dependent package. but need again to "Edit the /etc/openstack-dashboard/local_settings" and still it did not working so reboot it and check status. httpd seen as dead. then just do "systemctl start httpd" and yes FINALLY ITS WORK. (FOR OPENSTACK MITAKA)

hk gravatar imagehk ( 2016-06-15 14:40:57 -0500 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2016-05-19 10:00:45 -0500

Daitokuji gravatar image

I had the same error. Found that if I ran the command (/usr/bin/systemctl start httpd) manually it worked. Shut down server and increased resources from 1 to 2 cpu and from 2gb to 4gb ram. Was able to proceed past this error. Possible timeout setting somewhere that can be increased?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2016-03-29 18:31:17 -0500

Seen: 3,983 times

Last updated: Mar 29 '16