Ask Your Question
1

AMQPLAIN login refused: user 'guest' can only connect via localhost

asked 2016-03-25 14:27:00 -0500

Atif gravatar image

updated 2016-03-28 11:55:42 -0500

When I tried to run the following command, I got this error:-

command=  neutron net-create ext-net --shared --router:external=True

Error:-  "AMQPLAIN login refused: user 'guest' can only connect via localhost",

Suggestions please.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-04-06 18:14:52 -0500

dilip gravatar image

Sure the problem is with your rabbitmq server.By default guest user is accessible from localhost only. on the rabbitmq node create an user

sudo rabbitmqctl add_user {username} {password}

sudo rabbitmqctl set_permissions -p / {username} ".*" ".*" ".*"

sudo service rabbitmq-server restart

Then on the /etc/neutron/neutron.conf edit the following lines

rpc_backend = neutron.openstack.common.rpc.impl_kombu

rabbit_host = 10.1.0.13 # enter your rabbitmq ip

rabbit_userid = admin # enter rabbitmq username

rabbit_password = openstack1 # enter paasword for the above user

Restart all the neutron services

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-03-25 14:27:00 -0500

Seen: 3,141 times

Last updated: Apr 06 '16