Ask Your Question
0

OpenStack liberty installation: Keystone issue

asked 2016-03-25 04:00:36 -0500

Badis BA gravatar image

updated 2016-03-25 04:09:17 -0500

Hi guys,

I'm trying to install openstack liberty on Ubuntu 14.04 LTS and i'm following the openstack install guide on http://docs.openstack.org/.

The problem is that after i lunch this command : $ openstack service create --name keystone --description "OpenStack Identity" identity

i get this error : An unexpected error prevented the server from fulfilling your request (HTTP 5000)

is there any one who could help !!

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-03-25 04:55:00 -0500

Badis BA gravatar image

updated 2016-03-25 05:12:38 -0500

OK guys i solved this problem :) ,

First you have to check the ServerName in /etc/apache2/apache2.conf file and it have to be the same name of your controller machine example : if you named your machine Controller-Node , you must use the same name in that file and in the cmd : export OS_URL=http://Controller-Node:35357/v3.

Second thing if it dosent work just do this :

confirm that you've performed a database sync on the Keystone database :

su -s /bin/sh -c "keystone-manage db_sync" keystone.

and then restart the apache2 service:

service apache2 restart

edit flag offensive delete link more
0

answered 2016-03-25 04:47:27 -0500

updated 2016-03-25 04:48:00 -0500

Hello dear,

Please enable and start keystone service before run this command. I hope this problem will be solve.

Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-03-25 04:00:36 -0500

Seen: 144 times

Last updated: Mar 25 '16